{"answers":{"affected":"8 open source packages ship an affected version, including codewhale-tui, deepseek-tui and codewhale.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-75857 exists.","fix":"Upgrade codewhale-tui to 0.8.64 or later.","what":"CVE-2026-75857 is a high-severity vulnerability in Hmbown CodeWhale, published on 18 Aug 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2026-75857 and fix it if it is affected.\n\nWhat it is: CVE-2026-75857 is a high-severity vulnerability in Hmbown CodeWhale, published on 18 Aug 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-75857 exists.\n\nAffected packages and fixed versions:\n- codewhale-tui (crates.io): affected from 0.8.41; fixed in 0.8.64\n- codewhale-tui (crates.io): affected from 0.8.41; fixed in 0.8.64\n- deepseek-tui (crates.io): affected from 0.3.10 up to 0.8.41; no fix listed\n- deepseek-tui (crates.io): affected from 0.3.10 up to 0.8.41; no fix listed\n- codewhale (npm): affected from 0.8.41; fixed in 0.8.64\n- codewhale (npm): affected from 0.8.41; fixed in 0.8.64\n- deepseek-tui (npm): affected from 0.3.10; fixed in 0.8.41\n- deepseek-tui (npm): affected from 0.3.10; fixed in 0.8.41\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-75857/ (Markdown: https://insights.sbomify.com/CVE-2026-75857/index.md)","id":"CVE-2026-75857","markdown":"https://insights.sbomify.com/CVE-2026-75857/index.md","name":"CVE-2026-75857","record":{"aliases":["GHSA-g29h-pfmp-qp9r"],"analysis":{"component_type":"developer_tool","fix_type":"upgrade","impacts":["code_execution","privilege_escalation"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"AI coding assistant","requires_auth":"none","summary":"Attackers can execute arbitrary commands with elevated privileges by injecting instructions into an AI coding assistant's interactive shell tool.","user_interaction":"required","vuln_class":"privilege_escalation"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulnCheck","cpe":[],"cvss":{"score":7.3,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:L/AC:H/AT:P/PR:N/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-269","name":"Improper Privilege Management"}],"description":"CodeWhale versions \u003e= 0.3.10 and \u003c 0.8.64 (published as deepseek-tui \u003e= 0.3.10 and \u003c 0.8.41 on npm and 0.3.10 through 0.8.41 on crates.io, and as codewhale / codewhale-tui \u003e= 0.8.41 and \u003c 0.8.64) contain a vulnerability in the exec_shell_interact (alias exec_interact) tool, whose approval_requirement returns ApprovalRequirement::Auto. This overrides the default Required approval for code-executing tools, so LLM-controlled stdin is written into an already-approved long-running interactive shell (e.g., a python3 -i REPL, mysql, ssh, or sudo -i session) without any approval prompt. An attacker who can inject instructions via untrusted content the agent ingests (a fetched page, MCP result, or repo file) can cause commands to run at the privilege level of that approved process. Fixed in codewhale / codewhale-tui 0.8.64; the deprecated deepseek-tui crate has no fixed release.","ecosystems":["crates.io","npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"CodeWhale before 0.8.64 Privilege Escalation via exec_shell_interact","id":"CVE-2026-75857","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"crates.io","product":null,"products":[],"type":"privilege_escalation","year":"2026"},"n_packages":8,"n_references":3,"next":{"headline":"CodeWhale rlm_eval before 0.8.64 Remote Code Execution","id":"CVE-2026-75858"},"packages":[{"ecosystem":"crates.io","fixed":["0.8.64"],"introduced":["0.8.41"],"last_affected":[],"package":"codewhale-tui","purl":null,"source":"GHSA-g29h-pfmp-qp9r"},{"ecosystem":"crates.io","fixed":["0.8.64"],"introduced":["0.8.41"],"last_affected":[],"package":"codewhale-tui","purl":"pkg:cargo/codewhale-tui","source":"GHSA-g29h-pfmp-qp9r"},{"ecosystem":"crates.io","fixed":[],"introduced":["0.3.10"],"last_affected":["0.8.41"],"package":"deepseek-tui","purl":null,"source":"GHSA-g29h-pfmp-qp9r"},{"ecosystem":"crates.io","fixed":[],"introduced":["0.3.10"],"last_affected":["0.8.41"],"package":"deepseek-tui","purl":"pkg:cargo/deepseek-tui","source":"GHSA-g29h-pfmp-qp9r"},{"ecosystem":"npm","fixed":["0.8.64"],"introduced":["0.8.41"],"last_affected":[],"package":"codewhale","purl":null,"source":"GHSA-g29h-pfmp-qp9r"},{"ecosystem":"npm","fixed":["0.8.64"],"introduced":["0.8.41"],"last_affected":[],"package":"codewhale","purl":"pkg:npm/codewhale","source":"GHSA-g29h-pfmp-qp9r"},{"ecosystem":"npm","fixed":["0.8.41"],"introduced":["0.3.10"],"last_affected":[],"package":"deepseek-tui","purl":null,"source":"GHSA-g29h-pfmp-qp9r"},{"ecosystem":"npm","fixed":["0.8.41"],"introduced":["0.3.10"],"last_affected":[],"package":"deepseek-tui","purl":"pkg:npm/deepseek-tui","source":"GHSA-g29h-pfmp-qp9r"}],"prev":{"headline":"CodeWhale before 0.8.64 SSRF Bypass via DNS Pinning TOCTOU","id":"CVE-2026-75856"},"products":["CodeWhale"],"published":"2026-08-18","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-10-29","vendors":["Hmbown"]},"summary":"Attackers can execute arbitrary commands with elevated privileges by injecting instructions into an AI coding assistant's interactive shell tool.","url":"https://insights.sbomify.com/CVE-2026-75857/"}