CVE-2026-75858 CodeWhale rlm_eval before 0.8.64 Remote Code Execution
Attackers can execute arbitrary Python code on user machines via prompt injection in CodeWhale due to missing approval checks in rlm_eval.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Local or same network only
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2026-75858?
CVE-2026-75858 is a high-severity code injection vulnerability in Hmbown CodeWhale, published on 18 Aug 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Official description
CodeWhale (packages codewhale / codewhale-tui) versions >= 0.8.41 and < 0.8.64 contain a remote code execution vulnerability in the rlm_eval tool. The tool's approval_requirement() returns ApprovalRequirement::Auto, which the engine treats as 'never prompt,' causing arbitrary model-supplied Python code to run in a python3 interpreter without consulting the user's configured --approval-policy and without any approval prompt or audit step. An attacker can induce the agent to execute arbitrary code via prompt injection in untrusted content the agent reads (a web page, fetched URL, repository file, or MCP tool result); the companion rlm_open tool can stage such content. Code runs on the user's machine at the user's privilege level. Fixed in 0.8.64.
Weakness: CWE-94
Which versions are affected by CVE-2026-75858?
8 open source packages ship an affected version, including codewhale-tui, deepseek-tui and codewhale.
| Package | Affected | Fixed in |
|---|---|---|
codewhale-tui crates.io | From 0.8.41 | 0.8.64 |
codewhale-tui crates.io | From 0.8.41 | 0.8.64 |
deepseek-tui crates.io | From 0.8.33 to 0.8.41 | None |
deepseek-tui crates.io | From 0.8.33 to 0.8.41 | None |
codewhale npm | From 0.8.41 | 0.8.64 |
codewhale npm | From 0.8.41 | 0.8.64 |
2 more packages
deepseek-tui npm | From 0.8.33 | 0.8.41 |
deepseek-tui npm | From 0.8.33 | 0.8.41 |
How do I fix CVE-2026-75858?
Upgrade codewhale-tui to 0.8.64 or later.
Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.
Is CVE-2026-75858 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-75858 exists.
Sources
Also known as GHSA-wrj3-vj8c-784f.