# CVE-2026-75858: CodeWhale rlm_eval before 0.8.64 Remote Code Execution

> Attackers can execute arbitrary Python code on user machines via prompt injection in CodeWhale due to missing approval checks in rlm_eval.

- **Severity:** High 8.5 (`CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 18 Aug 2026
- **Updated:** 18 Aug 2026
- **Also known as:** GHSA-wrj3-vj8c-784f

## What is CVE-2026-75858?

CVE-2026-75858 is a high-severity code injection vulnerability in Hmbown CodeWhale, published on 18 Aug 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

CodeWhale (packages codewhale / codewhale-tui) versions >= 0.8.41 and < 0.8.64 contain a remote code execution vulnerability in the rlm_eval tool. The tool's approval_requirement() returns ApprovalRequirement::Auto, which the engine treats as 'never prompt,' causing arbitrary model-supplied Python code to run in a python3 interpreter without consulting the user's configured --approval-policy and without any approval prompt or audit step. An attacker can induce the agent to execute arbitrary code via prompt injection in untrusted content the agent reads (a web page, fetched URL, repository file, or MCP tool result); the companion rlm_open tool can stage such content. Code runs on the user's machine at the user's privilege level. Fixed in 0.8.64.

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2026-75858?

8 open source packages ship an affected version, including codewhale-tui, deepseek-tui and codewhale.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `codewhale-tui` | crates.io | From 0.8.41 | 0.8.64 |
| `codewhale-tui` | crates.io | From 0.8.41 | 0.8.64 |
| `deepseek-tui` | crates.io | From 0.8.33 to 0.8.41 | None |
| `deepseek-tui` | crates.io | From 0.8.33 to 0.8.41 | None |
| `codewhale` | npm | From 0.8.41 | 0.8.64 |
| `codewhale` | npm | From 0.8.41 | 0.8.64 |
| `deepseek-tui` | npm | From 0.8.33 | 0.8.41 |
| `deepseek-tui` | npm | From 0.8.33 | 0.8.41 |

## How do I fix CVE-2026-75858?

Upgrade codewhale-tui to 0.8.64 or later.

## Is CVE-2026-75858 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-75858 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-75858 and fix it if it is affected.

What it is: CVE-2026-75858 is a high-severity code injection vulnerability in Hmbown CodeWhale, published on 18 Aug 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-75858 exists.

Affected packages and fixed versions:
- codewhale-tui (crates.io): affected from 0.8.41; fixed in 0.8.64
- codewhale-tui (crates.io): affected from 0.8.41; fixed in 0.8.64
- deepseek-tui (crates.io): affected from 0.8.33 up to 0.8.41; no fix listed
- deepseek-tui (crates.io): affected from 0.8.33 up to 0.8.41; no fix listed
- codewhale (npm): affected from 0.8.41; fixed in 0.8.64
- codewhale (npm): affected from 0.8.41; fixed in 0.8.64
- deepseek-tui (npm): affected from 0.8.33; fixed in 0.8.41
- deepseek-tui (npm): affected from 0.8.33; fixed in 0.8.41

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-75858/ (Markdown: https://insights.sbomify.com/CVE-2026-75858/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-75858
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-75858
- OSV: https://osv.dev/vulnerability/CVE-2026-75858

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-75858/
Summaries are generated and may contain mistakes; the official description above is the record.
