CVE-2026-75899 fast-uri vulnerable to server-side request forgery via repeated hostname percent-decoding
An attacker can bypass host-policy checks and trigger server-side request forgery by exploiting double percent-decoding in the fast-uri library.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-75899?
CVE-2026-75899 is a high-severity server-side request forgery vulnerability in fast-uri, published on 24 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
fast-uri is a URI parser for Node.js. It decodes percent escapes in a hostname during parsing and then decodes the parsed hostname a second time during authority recomposition, so a single call to normalize or resolve can turn nested percent-encoded input into a different network destination such as a loopback hostname or address. For example, a doubly encoded host that spells out a loopback name decodes to that live host in one operation, which contradicts RFC 3986 section 2.4 that an implementation must not decode the same string more than once. An application that normalizes or resolves an untrusted HTTP-family URI before outbound routing, redirect validation, or a host-policy check can receive a destination different from the one the original encoded host represented, giving a server-side request forgery and host-policy bypass primitive. This is an incomplete-fix variant of CVE-2026-6322. The affected versions are 2.4.1 up to but not including 2.4.5, 3.1.2 up to but not including 3.1.6, and 4.0.0 up to but not including 4.1.3. The issue is fixed in 2.4.5, 3.1.6, and 4.1.3, which normalize percent escapes once and preserve encoded percent signs. Users should upgrade to a patched version.
Which versions are affected by CVE-2026-75899?
6 open source packages ship an affected version, including fast-uri. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
fast-uri npm | From 2.4.1 | 2.4.5 |
fast-uri npm | From 2.4.1 | 2.4.5 |
fast-uri npm | From 3.1.2 | 3.1.6 |
fast-uri npm | From 3.1.2 | 3.1.6 |
fast-uri npm | From 4.0.0 | 4.1.3 |
fast-uri npm | From 4.0.0 | 4.1.3 |
Products include Openjsf Fast-Uri.
How do I fix CVE-2026-75899?
Upgrade fast-uri to a fixed version for your release line: 2.4.5, 3.1.6 or 4.1.3.
Upgrade, and send outbound requests through an allow-list that blocks internal addresses. More about Server-side request forgery.
Is CVE-2026-75899 being exploited?
There is no known exploitation of CVE-2026-75899 in the wild and no public exploit code.
Other vulnerabilities in fast-uri
- CVE-2026-84292 fast-uri vulnerable to authority injection via an unvalidated port in serialize
- CVE-2026-84394 fast-uri vulnerable to host confusion via an unclosed bracket in the URI authority
- CVE-2026-75931 fast-uri vulnerable to host confusion via skipped IDN canonicalization on scheme-relative references
- CVE-2026-75975 fast-uri vulnerable to server-side request forgery via malformed IPv6 normalization
- CVE-2026-76172 fast-uri vulnerable to host confusion via percent-encoded scheme normalization
Sources
Also known as CLEANSTART-2026-GK02721, CLEANSTART-2026-NC17726, CLEANSTART-2026-PV08936, CLEANSTART-2026-SR09955, CLSA-2026-1792762888, DEBIAN-CVE-2026-75899 and 34 more.