{"answers":{"affected":"8 open source packages ship an affected version, including codewhale-tui, deepseek-tui and codewhale.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-75911 exists.","fix":"Upgrade codewhale-tui to 0.8.64 or later.","what":"CVE-2026-75911 is a high-severity command injection vulnerability in Hmbown CodeWhale, published on 18 Aug 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2026-75911 and fix it if it is affected.\n\nWhat it is: CVE-2026-75911 is a high-severity command injection vulnerability in Hmbown CodeWhale, published on 18 Aug 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-75911 exists.\n\nAffected packages and fixed versions:\n- codewhale-tui (crates.io): affected from 0.8.41; fixed in 0.8.64\n- codewhale-tui (crates.io): affected from 0.8.41; fixed in 0.8.64\n- deepseek-tui (crates.io): affected from 0.8.6 up to 0.8.41; no fix listed\n- deepseek-tui (crates.io): affected from 0.8.6 up to 0.8.41; no fix listed\n- codewhale (npm): affected from 0.8.41; fixed in 0.8.64\n- codewhale (npm): affected from 0.8.41; fixed in 0.8.64\n- deepseek-tui (npm): affected from 0.8.6; fixed in 0.8.41\n- deepseek-tui (npm): affected from 0.8.6; fixed in 0.8.41\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-75911/ (Markdown: https://insights.sbomify.com/CVE-2026-75911/index.md)","id":"CVE-2026-75911","markdown":"https://insights.sbomify.com/CVE-2026-75911/index.md","name":"CVE-2026-75911","record":{"aliases":["GHSA-gx45-xrj5-g6c4"],"analysis":{"component_type":"developer_tool","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"CodeWhale AI tool","requires_auth":"none","summary":"Attackers can execute arbitrary shell commands on victims' machines by committing a malicious config file to a repository opened in CodeWhale.","user_interaction":"required","vuln_class":"command_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulnCheck","cpe":[],"cvss":{"score":8.5,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-94","name":"Improper Control of Generation of Code"}],"description":"CodeWhale versions before 0.8.64 fail to properly validate the allow_shell configuration parameter from project config files, allowing attackers to enable arbitrary shell command execution by committing a malicious .codewhale/config.toml file to a repository. When a user clones and opens the repository in CodeWhale, the AI model gains access to exec_shell and task_shell tools, enabling execution of arbitrary shell commands on the victim's machine without explicit user consent.","ecosystems":["crates.io","npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"CodeWhale before 0.8.64 Remote Code Execution via allow_shell","id":"CVE-2026-75911","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"crates.io","product":null,"products":[],"type":"command_injection","year":"2026"},"n_packages":8,"n_references":3,"next":{"headline":"CodeWhale before 0.8.64 Argument Injection via git_blame","id":"CVE-2026-75912"},"packages":[{"ecosystem":"crates.io","fixed":["0.8.64"],"introduced":["0.8.41"],"last_affected":[],"package":"codewhale-tui","purl":null,"source":"GHSA-gx45-xrj5-g6c4"},{"ecosystem":"crates.io","fixed":["0.8.64"],"introduced":["0.8.41"],"last_affected":[],"package":"codewhale-tui","purl":"pkg:cargo/codewhale-tui","source":"GHSA-gx45-xrj5-g6c4"},{"ecosystem":"crates.io","fixed":[],"introduced":["0.8.6"],"last_affected":["0.8.41"],"package":"deepseek-tui","purl":null,"source":"GHSA-gx45-xrj5-g6c4"},{"ecosystem":"crates.io","fixed":[],"introduced":["0.8.6"],"last_affected":["0.8.41"],"package":"deepseek-tui","purl":"pkg:cargo/deepseek-tui","source":"GHSA-gx45-xrj5-g6c4"},{"ecosystem":"npm","fixed":["0.8.64"],"introduced":["0.8.41"],"last_affected":[],"package":"codewhale","purl":null,"source":"GHSA-gx45-xrj5-g6c4"},{"ecosystem":"npm","fixed":["0.8.64"],"introduced":["0.8.41"],"last_affected":[],"package":"codewhale","purl":"pkg:npm/codewhale","source":"GHSA-gx45-xrj5-g6c4"},{"ecosystem":"npm","fixed":["0.8.41"],"introduced":["0.8.6"],"last_affected":[],"package":"deepseek-tui","purl":null,"source":"GHSA-gx45-xrj5-g6c4"},{"ecosystem":"npm","fixed":["0.8.41"],"introduced":["0.8.6"],"last_affected":[],"package":"deepseek-tui","purl":"pkg:npm/deepseek-tui","source":"GHSA-gx45-xrj5-g6c4"}],"prev":{"headline":"Incorrect privilege assignment in the Amazon aws-athena-query-federation ClickHouse connector deployment template","id":"CVE-2026-75910"},"products":["CodeWhale"],"published":"2026-08-18","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-08-18","vendors":["Hmbown"]},"summary":"Attackers can execute arbitrary shell commands on victims' machines by committing a malicious config file to a repository opened in CodeWhale.","url":"https://insights.sbomify.com/CVE-2026-75911/"}