# CVE-2026-75911: CodeWhale before 0.8.64 Remote Code Execution via allow_shell

> Attackers can execute arbitrary shell commands on victims' machines by committing a malicious config file to a repository opened in CodeWhale.

- **Severity:** High 8.5 (`CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 18 Aug 2026
- **Updated:** 18 Aug 2026
- **Also known as:** GHSA-gx45-xrj5-g6c4

## What is CVE-2026-75911?

CVE-2026-75911 is a high-severity command injection vulnerability in Hmbown CodeWhale, published on 18 Aug 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

CodeWhale versions before 0.8.64 fail to properly validate the allow_shell configuration parameter from project config files, allowing attackers to enable arbitrary shell command execution by committing a malicious .codewhale/config.toml file to a repository. When a user clones and opens the repository in CodeWhale, the AI model gains access to exec_shell and task_shell tools, enabling execution of arbitrary shell commands on the victim's machine without explicit user consent.

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2026-75911?

8 open source packages ship an affected version, including codewhale-tui, deepseek-tui and codewhale.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `codewhale-tui` | crates.io | From 0.8.41 | 0.8.64 |
| `codewhale-tui` | crates.io | From 0.8.41 | 0.8.64 |
| `deepseek-tui` | crates.io | From 0.8.6 to 0.8.41 | None |
| `deepseek-tui` | crates.io | From 0.8.6 to 0.8.41 | None |
| `codewhale` | npm | From 0.8.41 | 0.8.64 |
| `codewhale` | npm | From 0.8.41 | 0.8.64 |
| `deepseek-tui` | npm | From 0.8.6 | 0.8.41 |
| `deepseek-tui` | npm | From 0.8.6 | 0.8.41 |

## How do I fix CVE-2026-75911?

Upgrade codewhale-tui to 0.8.64 or later.

## Is CVE-2026-75911 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-75911 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-75911 and fix it if it is affected.

What it is: CVE-2026-75911 is a high-severity command injection vulnerability in Hmbown CodeWhale, published on 18 Aug 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-75911 exists.

Affected packages and fixed versions:
- codewhale-tui (crates.io): affected from 0.8.41; fixed in 0.8.64
- codewhale-tui (crates.io): affected from 0.8.41; fixed in 0.8.64
- deepseek-tui (crates.io): affected from 0.8.6 up to 0.8.41; no fix listed
- deepseek-tui (crates.io): affected from 0.8.6 up to 0.8.41; no fix listed
- codewhale (npm): affected from 0.8.41; fixed in 0.8.64
- codewhale (npm): affected from 0.8.41; fixed in 0.8.64
- deepseek-tui (npm): affected from 0.8.6; fixed in 0.8.41
- deepseek-tui (npm): affected from 0.8.6; fixed in 0.8.41

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-75911/ (Markdown: https://insights.sbomify.com/CVE-2026-75911/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-75911
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-75911
- OSV: https://osv.dev/vulnerability/CVE-2026-75911

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-75911/
Summaries are generated and may contain mistakes; the official description above is the record.
