CVE-2026-75913 CodeWhale before 0.8.64 Argument Injection via git_show
Attackers can inject git arguments to write arbitrary files, enabling code execution or privilege escalation via prompt injection in CodeWhale.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2026-75913?
CVE-2026-75913 is a high-severity command injection vulnerability in Hmbown CodeWhale, published on 18 Aug 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
CodeWhale versions >= 0.3.27 and < 0.8.64 (published as deepseek-tui >= 0.3.27 and < 0.8.41 on npm and 0.3.27 through 0.8.41 on crates.io, and as codewhale / codewhale-tui >= 0.8.41 and < 0.8.64) contain an argument injection vulnerability in the git_show tool. The model-supplied rev parameter is passed unvalidated into the git show argv without an --end-of-options sentinel, so a value beginning with --output= is interpreted as a git flag. Because the tool is registered as auto-approved and advertised as read-only, an attacker (via a malicious repository combined with prompt injection) can cause an unprompted arbitrary file write at the privilege of the invoking user, targeting sensitive files such as ~/.ssh/authorized_keys, ~/.bashrc, or ~/.gitconfig. Fixed in codewhale / codewhale-tui 0.8.64 by adding rev validation; the deprecated deepseek-tui crate has no fixed release.
Weakness: CWE-73
Which versions are affected by CVE-2026-75913?
8 open source packages ship an affected version, including codewhale-tui, deepseek-tui and codewhale.
| Package | Affected | Fixed in |
|---|---|---|
codewhale-tui crates.io | From 0.8.41 | 0.8.64 |
codewhale-tui crates.io | From 0.8.41 | 0.8.64 |
deepseek-tui crates.io | From 0.3.27 to 0.8.41 | None |
deepseek-tui crates.io | From 0.3.27 to 0.8.41 | None |
codewhale npm | From 0.8.41 | 0.8.64 |
codewhale npm | From 0.8.41 | 0.8.64 |
2 more packages
deepseek-tui npm | From 0.3.27 | 0.8.41 |
deepseek-tui npm | From 0.3.27 | 0.8.41 |
How do I fix CVE-2026-75913?
Upgrade codewhale-tui to 0.8.64 or later.
Upgrade, and pass arguments to programs as a list instead of through a shell. More about Command injection.
Is CVE-2026-75913 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-75913 exists.
Sources
Also known as GHSA-7j5w-7r7x-9v27.