{"answers":{"affected":"8 open source packages ship an affected version, including codewhale-tui, deepseek-tui and codewhale.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-75913 exists.","fix":"Upgrade codewhale-tui to 0.8.64 or later.","what":"CVE-2026-75913 is a high-severity command injection vulnerability in Hmbown CodeWhale, published on 18 Aug 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2026-75913 and fix it if it is affected.\n\nWhat it is: CVE-2026-75913 is a high-severity command injection vulnerability in Hmbown CodeWhale, published on 18 Aug 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-75913 exists.\n\nAffected packages and fixed versions:\n- codewhale-tui (crates.io): affected from 0.8.41; fixed in 0.8.64\n- codewhale-tui (crates.io): affected from 0.8.41; fixed in 0.8.64\n- deepseek-tui (crates.io): affected from 0.3.27 up to 0.8.41; no fix listed\n- deepseek-tui (crates.io): affected from 0.3.27 up to 0.8.41; no fix listed\n- codewhale (npm): affected from 0.8.41; fixed in 0.8.64\n- codewhale (npm): affected from 0.8.41; fixed in 0.8.64\n- deepseek-tui (npm): affected from 0.3.27; fixed in 0.8.41\n- deepseek-tui (npm): affected from 0.3.27; fixed in 0.8.41\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-75913/ (Markdown: https://insights.sbomify.com/CVE-2026-75913/index.md)","id":"CVE-2026-75913","markdown":"https://insights.sbomify.com/CVE-2026-75913/index.md","name":"CVE-2026-75913","record":{"aliases":["GHSA-7j5w-7r7x-9v27"],"analysis":{"component_type":"developer_tool","fix_type":"upgrade","impacts":["code_execution","privilege_escalation"],"network_reachable":"yes","non_default_config":false,"product_category":"CodeWhale CLI tool","requires_auth":"none","summary":"Attackers can inject git arguments to write arbitrary files, enabling code execution or privilege escalation via prompt injection in CodeWhale.","user_interaction":"required","vuln_class":"command_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulnCheck","cpe":[],"cvss":{"score":8.5,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:H/VA:H/SC:N/SI:H/SA:H","version":"4.0"},"cwes":[{"id":"CWE-73","name":"External Control of File Name or Path"}],"description":"CodeWhale versions \u003e= 0.3.27 and \u003c 0.8.64 (published as deepseek-tui \u003e= 0.3.27 and \u003c 0.8.41 on npm and 0.3.27 through 0.8.41 on crates.io, and as codewhale / codewhale-tui \u003e= 0.8.41 and \u003c 0.8.64) contain an argument injection vulnerability in the git_show tool. The model-supplied rev parameter is passed unvalidated into the git show argv without an --end-of-options sentinel, so a value beginning with --output= is interpreted as a git flag. Because the tool is registered as auto-approved and advertised as read-only, an attacker (via a malicious repository combined with prompt injection) can cause an unprompted arbitrary file write at the privilege of the invoking user, targeting sensitive files such as ~/.ssh/authorized_keys, ~/.bashrc, or ~/.gitconfig. Fixed in codewhale / codewhale-tui 0.8.64 by adding rev validation; the deprecated deepseek-tui crate has no fixed release.","ecosystems":["crates.io","npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"CodeWhale before 0.8.64 Argument Injection via git_show","id":"CVE-2026-75913","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"crates.io","product":null,"products":[],"type":"command_injection","year":"2026"},"n_packages":8,"n_references":3,"next":{"headline":"CodeWhale before 0.8.64 Path Traversal via image_analyze symlink","id":"CVE-2026-75914"},"packages":[{"ecosystem":"crates.io","fixed":["0.8.64"],"introduced":["0.8.41"],"last_affected":[],"package":"codewhale-tui","purl":null,"source":"GHSA-7j5w-7r7x-9v27"},{"ecosystem":"crates.io","fixed":["0.8.64"],"introduced":["0.8.41"],"last_affected":[],"package":"codewhale-tui","purl":"pkg:cargo/codewhale-tui","source":"GHSA-7j5w-7r7x-9v27"},{"ecosystem":"crates.io","fixed":[],"introduced":["0.3.27"],"last_affected":["0.8.41"],"package":"deepseek-tui","purl":null,"source":"GHSA-7j5w-7r7x-9v27"},{"ecosystem":"crates.io","fixed":[],"introduced":["0.3.27"],"last_affected":["0.8.41"],"package":"deepseek-tui","purl":"pkg:cargo/deepseek-tui","source":"GHSA-7j5w-7r7x-9v27"},{"ecosystem":"npm","fixed":["0.8.64"],"introduced":["0.8.41"],"last_affected":[],"package":"codewhale","purl":null,"source":"GHSA-7j5w-7r7x-9v27"},{"ecosystem":"npm","fixed":["0.8.64"],"introduced":["0.8.41"],"last_affected":[],"package":"codewhale","purl":"pkg:npm/codewhale","source":"GHSA-7j5w-7r7x-9v27"},{"ecosystem":"npm","fixed":["0.8.41"],"introduced":["0.3.27"],"last_affected":[],"package":"deepseek-tui","purl":null,"source":"GHSA-7j5w-7r7x-9v27"},{"ecosystem":"npm","fixed":["0.8.41"],"introduced":["0.3.27"],"last_affected":[],"package":"deepseek-tui","purl":"pkg:npm/deepseek-tui","source":"GHSA-7j5w-7r7x-9v27"}],"prev":{"headline":"CodeWhale before 0.8.64 Argument Injection via git_blame","id":"CVE-2026-75912"},"products":["CodeWhale"],"published":"2026-08-18","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-10-29","vendors":["Hmbown"]},"summary":"Attackers can inject git arguments to write arbitrary files, enabling code execution or privilege escalation via prompt injection in CodeWhale.","url":"https://insights.sbomify.com/CVE-2026-75913/"}