# CVE-2026-75913: CodeWhale before 0.8.64 Argument Injection via git_show

> Attackers can inject git arguments to write arbitrary files, enabling code execution or privilege escalation via prompt injection in CodeWhale.

- **Severity:** High 8.5 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:H/VA:H/SC:N/SI:H/SA:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 18 Aug 2026
- **Updated:** 29 Oct 2026
- **Also known as:** GHSA-7j5w-7r7x-9v27

## What is CVE-2026-75913?

CVE-2026-75913 is a high-severity command injection vulnerability in Hmbown CodeWhale, published on 18 Aug 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

CodeWhale versions >= 0.3.27 and < 0.8.64 (published as deepseek-tui >= 0.3.27 and < 0.8.41 on npm and 0.3.27 through 0.8.41 on crates.io, and as codewhale / codewhale-tui >= 0.8.41 and < 0.8.64) contain an argument injection vulnerability in the git_show tool. The model-supplied rev parameter is passed unvalidated into the git show argv without an --end-of-options sentinel, so a value beginning with --output= is interpreted as a git flag. Because the tool is registered as auto-approved and advertised as read-only, an attacker (via a malicious repository combined with prompt injection) can cause an unprompted arbitrary file write at the privilege of the invoking user, targeting sensitive files such as ~/.ssh/authorized_keys, ~/.bashrc, or ~/.gitconfig. Fixed in codewhale / codewhale-tui 0.8.64 by adding rev validation; the deprecated deepseek-tui crate has no fixed release.

Weakness: CWE-73 (External Control of File Name or Path)

## Which versions are affected by CVE-2026-75913?

8 open source packages ship an affected version, including codewhale-tui, deepseek-tui and codewhale.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `codewhale-tui` | crates.io | From 0.8.41 | 0.8.64 |
| `codewhale-tui` | crates.io | From 0.8.41 | 0.8.64 |
| `deepseek-tui` | crates.io | From 0.3.27 to 0.8.41 | None |
| `deepseek-tui` | crates.io | From 0.3.27 to 0.8.41 | None |
| `codewhale` | npm | From 0.8.41 | 0.8.64 |
| `codewhale` | npm | From 0.8.41 | 0.8.64 |
| `deepseek-tui` | npm | From 0.3.27 | 0.8.41 |
| `deepseek-tui` | npm | From 0.3.27 | 0.8.41 |

## How do I fix CVE-2026-75913?

Upgrade codewhale-tui to 0.8.64 or later.

## Is CVE-2026-75913 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-75913 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-75913 and fix it if it is affected.

What it is: CVE-2026-75913 is a high-severity command injection vulnerability in Hmbown CodeWhale, published on 18 Aug 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-75913 exists.

Affected packages and fixed versions:
- codewhale-tui (crates.io): affected from 0.8.41; fixed in 0.8.64
- codewhale-tui (crates.io): affected from 0.8.41; fixed in 0.8.64
- deepseek-tui (crates.io): affected from 0.3.27 up to 0.8.41; no fix listed
- deepseek-tui (crates.io): affected from 0.3.27 up to 0.8.41; no fix listed
- codewhale (npm): affected from 0.8.41; fixed in 0.8.64
- codewhale (npm): affected from 0.8.41; fixed in 0.8.64
- deepseek-tui (npm): affected from 0.3.27; fixed in 0.8.41
- deepseek-tui (npm): affected from 0.3.27; fixed in 0.8.41

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-75913/ (Markdown: https://insights.sbomify.com/CVE-2026-75913/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-75913
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-75913
- OSV: https://osv.dev/vulnerability/CVE-2026-75913

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-75913/
Summaries are generated and may contain mistakes; the official description above is the record.
