{"answers":{"affected":"8 open source packages ship an affected version, including codewhale-tui, deepseek-tui and codewhale.","exploited":"There is no known exploitation of CVE-2026-75914 in the wild and no public exploit code.","fix":"Upgrade codewhale-tui to 0.8.64 or later.","what":"CVE-2026-75914 is a high-severity vulnerability in Hmbown CodeWhale, published on 18 Aug 2026."},"fix_prompt":"Check this codebase for CVE-2026-75914 and fix it if it is affected.\n\nWhat it is: CVE-2026-75914 is a high-severity vulnerability in Hmbown CodeWhale, published on 18 Aug 2026. \nExploitation: There is no known exploitation of CVE-2026-75914 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- codewhale-tui (crates.io): affected from 0.8.41; fixed in 0.8.64\n- codewhale-tui (crates.io): affected from 0.8.41; fixed in 0.8.64\n- deepseek-tui (crates.io): affected from 0.8.32 up to 0.8.41; no fix listed\n- deepseek-tui (crates.io): affected from 0.8.32 up to 0.8.41; no fix listed\n- codewhale (npm): affected from 0.8.41; fixed in 0.8.64\n- codewhale (npm): affected from 0.8.41; fixed in 0.8.64\n- deepseek-tui (npm): affected from 0.8.32; fixed in 0.8.41\n- deepseek-tui (npm): affected from 0.8.32; fixed in 0.8.41\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-75914/ (Markdown: https://insights.sbomify.com/CVE-2026-75914/index.md)","id":"CVE-2026-75914","markdown":"https://insights.sbomify.com/CVE-2026-75914/index.md","name":"CVE-2026-75914","record":{"aliases":["GHSA-w7wx-5q49-r59w"],"analysis":null,"analysis_generated_by":null,"assigner":"VulnCheck","cpe":[],"cvss":{"score":8.7,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-22","name":"Improper Limitation of a Pathname to a Restricted Directory"}],"description":"CodeWhale versions before 0.8.64 contain a path traversal vulnerability in the image_analyze tool that fails to canonicalize symlinks before reading files. Attackers can create workspace symlinks pointing to external files with image extensions to leak file bytes to the vision endpoint without user approval.","ecosystems":["crates.io","npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"CodeWhale before 0.8.64 Path Traversal via image_analyze symlink","id":"CVE-2026-75914","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"crates.io","product":null,"products":[],"type":null,"year":"2026"},"n_packages":8,"n_references":3,"next":{"headline":"CodeWhale before 0.8.64 Environment Variable Leak via js_execution","id":"CVE-2026-75915"},"packages":[{"ecosystem":"crates.io","fixed":["0.8.64"],"introduced":["0.8.41"],"last_affected":[],"package":"codewhale-tui","purl":null,"source":"GHSA-w7wx-5q49-r59w"},{"ecosystem":"crates.io","fixed":["0.8.64"],"introduced":["0.8.41"],"last_affected":[],"package":"codewhale-tui","purl":"pkg:cargo/codewhale-tui","source":"GHSA-w7wx-5q49-r59w"},{"ecosystem":"crates.io","fixed":[],"introduced":["0.8.32"],"last_affected":["0.8.41"],"package":"deepseek-tui","purl":null,"source":"GHSA-w7wx-5q49-r59w"},{"ecosystem":"crates.io","fixed":[],"introduced":["0.8.32"],"last_affected":["0.8.41"],"package":"deepseek-tui","purl":"pkg:cargo/deepseek-tui","source":"GHSA-w7wx-5q49-r59w"},{"ecosystem":"npm","fixed":["0.8.64"],"introduced":["0.8.41"],"last_affected":[],"package":"codewhale","purl":null,"source":"GHSA-w7wx-5q49-r59w"},{"ecosystem":"npm","fixed":["0.8.64"],"introduced":["0.8.41"],"last_affected":[],"package":"codewhale","purl":"pkg:npm/codewhale","source":"GHSA-w7wx-5q49-r59w"},{"ecosystem":"npm","fixed":["0.8.41"],"introduced":["0.8.32"],"last_affected":[],"package":"deepseek-tui","purl":null,"source":"GHSA-w7wx-5q49-r59w"},{"ecosystem":"npm","fixed":["0.8.41"],"introduced":["0.8.32"],"last_affected":[],"package":"deepseek-tui","purl":"pkg:npm/deepseek-tui","source":"GHSA-w7wx-5q49-r59w"}],"prev":{"headline":"CodeWhale before 0.8.64 Argument Injection via git_show","id":"CVE-2026-75913"},"products":["CodeWhale"],"published":"2026-08-18","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-08-20","vendors":["Hmbown"]},"summary":null,"url":"https://insights.sbomify.com/CVE-2026-75914/"}