# CVE-2026-75914: CodeWhale before 0.8.64 Path Traversal via image_analyze symlink


- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 18 Aug 2026
- **Updated:** 20 Aug 2026
- **Also known as:** GHSA-w7wx-5q49-r59w

## What is CVE-2026-75914?

CVE-2026-75914 is a high-severity vulnerability in Hmbown CodeWhale, published on 18 Aug 2026. 

### Official description

CodeWhale versions before 0.8.64 contain a path traversal vulnerability in the image_analyze tool that fails to canonicalize symlinks before reading files. Attackers can create workspace symlinks pointing to external files with image extensions to leak file bytes to the vision endpoint without user approval.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2026-75914?

8 open source packages ship an affected version, including codewhale-tui, deepseek-tui and codewhale.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `codewhale-tui` | crates.io | From 0.8.41 | 0.8.64 |
| `codewhale-tui` | crates.io | From 0.8.41 | 0.8.64 |
| `deepseek-tui` | crates.io | From 0.8.32 to 0.8.41 | None |
| `deepseek-tui` | crates.io | From 0.8.32 to 0.8.41 | None |
| `codewhale` | npm | From 0.8.41 | 0.8.64 |
| `codewhale` | npm | From 0.8.41 | 0.8.64 |
| `deepseek-tui` | npm | From 0.8.32 | 0.8.41 |
| `deepseek-tui` | npm | From 0.8.32 | 0.8.41 |

## How do I fix CVE-2026-75914?

Upgrade codewhale-tui to 0.8.64 or later.

## Is CVE-2026-75914 being exploited?

There is no known exploitation of CVE-2026-75914 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-75914 and fix it if it is affected.

What it is: CVE-2026-75914 is a high-severity vulnerability in Hmbown CodeWhale, published on 18 Aug 2026. 
Exploitation: There is no known exploitation of CVE-2026-75914 in the wild and no public exploit code.

Affected packages and fixed versions:
- codewhale-tui (crates.io): affected from 0.8.41; fixed in 0.8.64
- codewhale-tui (crates.io): affected from 0.8.41; fixed in 0.8.64
- deepseek-tui (crates.io): affected from 0.8.32 up to 0.8.41; no fix listed
- deepseek-tui (crates.io): affected from 0.8.32 up to 0.8.41; no fix listed
- codewhale (npm): affected from 0.8.41; fixed in 0.8.64
- codewhale (npm): affected from 0.8.41; fixed in 0.8.64
- deepseek-tui (npm): affected from 0.8.32; fixed in 0.8.41
- deepseek-tui (npm): affected from 0.8.32; fixed in 0.8.41

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-75914/ (Markdown: https://insights.sbomify.com/CVE-2026-75914/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-75914
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-75914
- OSV: https://osv.dev/vulnerability/CVE-2026-75914

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-75914/
Summaries are generated and may contain mistakes; the official description above is the record.
