{"answers":{"affected":"8 open source packages ship an affected version, including codewhale-tui, deepseek-tui and codewhale.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-75915 exists.","fix":"Upgrade codewhale-tui to 0.8.64 or later.","what":"CVE-2026-75915 is a high-severity vulnerability in Hmbown CodeWhale, published on 18 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-75915 and fix it if it is affected.\n\nWhat it is: CVE-2026-75915 is a high-severity vulnerability in Hmbown CodeWhale, published on 18 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-75915 exists.\n\nAffected packages and fixed versions:\n- codewhale-tui (crates.io): affected from 0.8.41; fixed in 0.8.64\n- codewhale-tui (crates.io): affected from 0.8.41; fixed in 0.8.64\n- deepseek-tui (crates.io): affected from 0.8.32 up to 0.8.41; no fix listed\n- deepseek-tui (crates.io): affected from 0.8.32 up to 0.8.41; no fix listed\n- codewhale (npm): affected from 0.8.41; fixed in 0.8.64\n- codewhale (npm): affected from 0.8.41; fixed in 0.8.64\n- deepseek-tui (npm): affected from 0.8.32; fixed in 0.8.41\n- deepseek-tui (npm): affected from 0.8.32; fixed in 0.8.41\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-75915/ (Markdown: https://insights.sbomify.com/CVE-2026-75915/index.md)","id":"CVE-2026-75915","markdown":"https://insights.sbomify.com/CVE-2026-75915/index.md","name":"CVE-2026-75915","record":{"aliases":["GHSA-h539-c7r8-3xq4"],"analysis":{"component_type":"developer_tool","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"CodeWhale AI tool","requires_auth":"none","summary":"Attackers can leak sensitive environment variables like API keys by executing malicious JavaScript in the CodeWhale tool.","user_interaction":"not_required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulnCheck","cpe":[],"cvss":{"score":8.7,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-200","name":"Exposure of Sensitive Information to an Unauthorized Actor"}],"description":"CodeWhale versions before 0.8.64 contain an environment variable exposure vulnerability in the js_execution tool that fails to scrub parent process environment variables before spawning Node.js. Attackers can craft malicious JavaScript code executed by the tool to read process.env and leak API keys, cloud credentials, and authentication tokens back to the model context.","ecosystems":["crates.io","npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"CodeWhale before 0.8.64 Environment Variable Leak via js_execution","id":"CVE-2026-75915","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"crates.io","product":null,"products":[],"type":"information_disclosure","year":"2026"},"n_packages":8,"n_references":3,"next":{"headline":"SiYuan XSS-to-RCE via unescaped block metadata in hint popup","id":"CVE-2026-75916"},"packages":[{"ecosystem":"crates.io","fixed":["0.8.64"],"introduced":["0.8.41"],"last_affected":[],"package":"codewhale-tui","purl":null,"source":"GHSA-h539-c7r8-3xq4"},{"ecosystem":"crates.io","fixed":["0.8.64"],"introduced":["0.8.41"],"last_affected":[],"package":"codewhale-tui","purl":"pkg:cargo/codewhale-tui","source":"GHSA-h539-c7r8-3xq4"},{"ecosystem":"crates.io","fixed":[],"introduced":["0.8.32"],"last_affected":["0.8.41"],"package":"deepseek-tui","purl":null,"source":"GHSA-h539-c7r8-3xq4"},{"ecosystem":"crates.io","fixed":[],"introduced":["0.8.32"],"last_affected":["0.8.41"],"package":"deepseek-tui","purl":"pkg:cargo/deepseek-tui","source":"GHSA-h539-c7r8-3xq4"},{"ecosystem":"npm","fixed":["0.8.64"],"introduced":["0.8.41"],"last_affected":[],"package":"codewhale","purl":null,"source":"GHSA-h539-c7r8-3xq4"},{"ecosystem":"npm","fixed":["0.8.64"],"introduced":["0.8.41"],"last_affected":[],"package":"codewhale","purl":"pkg:npm/codewhale","source":"GHSA-h539-c7r8-3xq4"},{"ecosystem":"npm","fixed":["0.8.41"],"introduced":["0.8.32"],"last_affected":[],"package":"deepseek-tui","purl":null,"source":"GHSA-h539-c7r8-3xq4"},{"ecosystem":"npm","fixed":["0.8.41"],"introduced":["0.8.32"],"last_affected":[],"package":"deepseek-tui","purl":"pkg:npm/deepseek-tui","source":"GHSA-h539-c7r8-3xq4"}],"prev":{"headline":"CodeWhale before 0.8.64 Path Traversal via image_analyze symlink","id":"CVE-2026-75914"},"products":["CodeWhale"],"published":"2026-08-18","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-08-18","vendors":["Hmbown"]},"summary":"Attackers can leak sensitive environment variables like API keys by executing malicious JavaScript in the CodeWhale tool.","url":"https://insights.sbomify.com/CVE-2026-75915/"}