# CVE-2026-75915: CodeWhale before 0.8.64 Environment Variable Leak via js_execution

> Attackers can leak sensitive environment variables like API keys by executing malicious JavaScript in the CodeWhale tool.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 18 Aug 2026
- **Updated:** 18 Aug 2026
- **Also known as:** GHSA-h539-c7r8-3xq4

## What is CVE-2026-75915?

CVE-2026-75915 is a high-severity vulnerability in Hmbown CodeWhale, published on 18 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

CodeWhale versions before 0.8.64 contain an environment variable exposure vulnerability in the js_execution tool that fails to scrub parent process environment variables before spawning Node.js. Attackers can craft malicious JavaScript code executed by the tool to read process.env and leak API keys, cloud credentials, and authentication tokens back to the model context.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2026-75915?

8 open source packages ship an affected version, including codewhale-tui, deepseek-tui and codewhale.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `codewhale-tui` | crates.io | From 0.8.41 | 0.8.64 |
| `codewhale-tui` | crates.io | From 0.8.41 | 0.8.64 |
| `deepseek-tui` | crates.io | From 0.8.32 to 0.8.41 | None |
| `deepseek-tui` | crates.io | From 0.8.32 to 0.8.41 | None |
| `codewhale` | npm | From 0.8.41 | 0.8.64 |
| `codewhale` | npm | From 0.8.41 | 0.8.64 |
| `deepseek-tui` | npm | From 0.8.32 | 0.8.41 |
| `deepseek-tui` | npm | From 0.8.32 | 0.8.41 |

## How do I fix CVE-2026-75915?

Upgrade codewhale-tui to 0.8.64 or later.

## Is CVE-2026-75915 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-75915 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-75915 and fix it if it is affected.

What it is: CVE-2026-75915 is a high-severity vulnerability in Hmbown CodeWhale, published on 18 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-75915 exists.

Affected packages and fixed versions:
- codewhale-tui (crates.io): affected from 0.8.41; fixed in 0.8.64
- codewhale-tui (crates.io): affected from 0.8.41; fixed in 0.8.64
- deepseek-tui (crates.io): affected from 0.8.32 up to 0.8.41; no fix listed
- deepseek-tui (crates.io): affected from 0.8.32 up to 0.8.41; no fix listed
- codewhale (npm): affected from 0.8.41; fixed in 0.8.64
- codewhale (npm): affected from 0.8.41; fixed in 0.8.64
- deepseek-tui (npm): affected from 0.8.32; fixed in 0.8.41
- deepseek-tui (npm): affected from 0.8.32; fixed in 0.8.41

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-75915/ (Markdown: https://insights.sbomify.com/CVE-2026-75915/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-75915
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-75915
- OSV: https://osv.dev/vulnerability/CVE-2026-75915

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-75915/
Summaries are generated and may contain mistakes; the official description above is the record.
