CVE-2026-75931 fast-uri vulnerable to host confusion via skipped IDN canonicalization on scheme-relative references
An attacker can bypass host-based security policies in applications using fast-uri by exploiting inconsistent IDN canonicalization on scheme-relative references.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-75931?
CVE-2026-75931 is a high-severity vulnerability in fast-uri, published on 24 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
fast-uri is a URI parser for Node.js. It canonicalizes a host to its ASCII form only when the input carries an explicit scheme, so a scheme-relative reference such as a host preceded by two slashes is returned with its host verbatim and no error set. As a result fast-uri's own entry points disagree with each other: parse, resolve, normalize, and equal can yield different hosts for the same input depending only on whether a scheme is written out, and equal can return opposite verdicts for the same pair of hosts. An application that extracts a host with fast-uri to check it against a policy list and then resolves the same reference can make its decision on one host while the destination is another, enabling host confusion and policy bypass. The affected versions are 2.4.2 up to but not including 2.4.5, 3.1.3 up to but not including 3.1.6, and 4.0.1 up to but not including 4.1.3. The issue is fixed in 2.4.5, 3.1.6, and 4.1.3, which canonicalize the host consistently across the resolve path. Users should upgrade to a patched version.
Weakness: CWE-436
Which versions are affected by CVE-2026-75931?
6 open source packages ship an affected version, including fast-uri. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
fast-uri npm | From 2.4.2 | 2.4.5 |
fast-uri npm | From 2.4.2 | 2.4.5 |
fast-uri npm | From 3.1.3 | 3.1.6 |
fast-uri npm | From 3.1.3 | 3.1.6 |
fast-uri npm | From 4.0.1 | 4.1.3 |
fast-uri npm | From 4.0.1 | 4.1.3 |
Products include Openjsf Fast-Uri.
How do I fix CVE-2026-75931?
Upgrade fast-uri to a fixed version for your release line: 2.4.5, 3.1.6 or 4.1.3.
Is CVE-2026-75931 being exploited?
There is no known exploitation of CVE-2026-75931 in the wild and no public exploit code.
Other vulnerabilities in fast-uri
- CVE-2026-84292 fast-uri vulnerable to authority injection via an unvalidated port in serialize
- CVE-2026-84394 fast-uri vulnerable to host confusion via an unclosed bracket in the URI authority
- CVE-2026-75899 fast-uri vulnerable to server-side request forgery via repeated hostname percent-decoding
- CVE-2026-75975 fast-uri vulnerable to server-side request forgery via malformed IPv6 normalization
- CVE-2026-76172 fast-uri vulnerable to host confusion via percent-encoded scheme normalization
Sources
Also known as CLEANSTART-2026-BZ85863, CLEANSTART-2026-GL35722, CLEANSTART-2026-UO74243, CLSA-2026-1790854678, DEBIAN-CVE-2026-75931, ECHO-18b9-6831-71fe and 24 more.