# CVE-2026-75931: fast-uri vulnerable to host confusion via skipped IDN canonicalization on scheme-relative references

> An attacker can bypass host-based security policies in applications using fast-uri by exploiting inconsistent IDN canonicalization on scheme-relative references.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 24 Aug 2026
- **Updated:** 24 Aug 2026
- **Also known as:** CLEANSTART-2026-BZ85863, CLEANSTART-2026-GL35722, CLEANSTART-2026-UO74243, CLSA-2026-1790854678, DEBIAN-CVE-2026-75931, ECHO-18b9-6831-71fe, GHSA-5jgf-p345-68v8, MINI-24pp-fv6r-qc87, MINI-3748-6683-p768, MINI-3c8f-rv7r-7r4w, MINI-3v3j-pw5c-w95f, MINI-3whg-gwxf-mgjp, MINI-463q-6qfm-6j6x, MINI-49mg-mm9w-vj46, MINI-5583-j5cj-h4c4, MINI-55qx-78w8-m73r, MINI-5pcp-rg84-465m, MINI-7q76-7gmc-xvrp, MINI-8875-hpxc-f97g, MINI-8p8w-7x84-8fc9, MINI-fcvm-vgpw-723h, MINI-fg5p-gm7f-4w49, MINI-g5w4-cq3m-4m8r, MINI-h6qx-7pvf-jhvx, MINI-hr5v-vx9j-qwqc, MINI-mxh7-rvcv-grq6, MINI-pjf5-qpwf-xv6p, MINI-xw4j-fjfw-ccph, ROOT-APP-NPM-CVE-2026-75931, UBUNTU-CVE-2026-75931

## What is CVE-2026-75931?

CVE-2026-75931 is a high-severity vulnerability in fast-uri, published on 24 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

fast-uri is a URI parser for Node.js. It canonicalizes a host to its ASCII form only when the input carries an explicit scheme, so a scheme-relative reference such as a host preceded by two slashes is returned with its host verbatim and no error set. As a result fast-uri's own entry points disagree with each other: parse, resolve, normalize, and equal can yield different hosts for the same input depending only on whether a scheme is written out, and equal can return opposite verdicts for the same pair of hosts. An application that extracts a host with fast-uri to check it against a policy list and then resolves the same reference can make its decision on one host while the destination is another, enabling host confusion and policy bypass. The affected versions are 2.4.2 up to but not including 2.4.5, 3.1.3 up to but not including 3.1.6, and 4.0.1 up to but not including 4.1.3. The issue is fixed in 2.4.5, 3.1.6, and 4.1.3, which canonicalize the host consistently across the resolve path. Users should upgrade to a patched version.

Weakness: CWE-436 (Interpretation Conflict)

## Which versions are affected by CVE-2026-75931?

6 open source packages ship an affected version, including fast-uri. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `fast-uri` | npm | From 2.4.2 | 2.4.5 |
| `fast-uri` | npm | From 2.4.2 | 2.4.5 |
| `fast-uri` | npm | From 3.1.3 | 3.1.6 |
| `fast-uri` | npm | From 3.1.3 | 3.1.6 |
| `fast-uri` | npm | From 4.0.1 | 4.1.3 |
| `fast-uri` | npm | From 4.0.1 | 4.1.3 |

Products: Openjsf Fast-Uri.

## How do I fix CVE-2026-75931?

Upgrade fast-uri to a fixed version for your release line: 2.4.5, 3.1.6 or 4.1.3.

## Is CVE-2026-75931 being exploited?

There is no known exploitation of CVE-2026-75931 in the wild and no public exploit code.

## Other vulnerabilities in fast-uri

- [CVE-2026-84292](https://insights.sbomify.com/CVE-2026-84292/): fast-uri vulnerable to authority injection via an unvalidated port in serialize (high 7.5)
- [CVE-2026-84394](https://insights.sbomify.com/CVE-2026-84394/): fast-uri vulnerable to host confusion via an unclosed bracket in the URI authority (high 7.5)
- [CVE-2026-75899](https://insights.sbomify.com/CVE-2026-75899/): fast-uri vulnerable to server-side request forgery via repeated hostname percent-decoding (high 7.5)
- [CVE-2026-75975](https://insights.sbomify.com/CVE-2026-75975/): fast-uri vulnerable to server-side request forgery via malformed IPv6 normalization (high 7.5)
- [CVE-2026-76172](https://insights.sbomify.com/CVE-2026-76172/): fast-uri vulnerable to host confusion via percent-encoded scheme normalization (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-75931 and fix it if it is affected.

What it is: CVE-2026-75931 is a high-severity vulnerability in fast-uri, published on 24 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-75931 in the wild and no public exploit code.

Affected packages and fixed versions:
- fast-uri (npm): affected from 2.4.2; fixed in 2.4.5
- fast-uri (npm): affected from 2.4.2; fixed in 2.4.5
- fast-uri (npm): affected from 3.1.3; fixed in 3.1.6
- fast-uri (npm): affected from 3.1.3; fixed in 3.1.6
- fast-uri (npm): affected from 4.0.1; fixed in 4.1.3
- fast-uri (npm): affected from 4.0.1; fixed in 4.1.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-75931/ (Markdown: https://insights.sbomify.com/CVE-2026-75931/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-75931
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-75931
- OSV: https://osv.dev/vulnerability/CVE-2026-75931

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-75931/
Summaries are generated and may contain mistakes; the official description above is the record.
