# CVE-2026-75935: Memory-amplification denial of service via declared-length preallocation in Amazon ion-java

> Remote attackers can cause denial of service in applications using Amazon ion-java by sending crafted binary documents that trigger excessive memory allocation.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 18 Aug 2026
- **Updated:** 19 Aug 2026
- **Also known as:** GHSA-822f-6gg9-whr5

## What is CVE-2026-75935?

CVE-2026-75935 is a high-severity denial of service vulnerability in Amazon Ion Java, published on 18 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Uncontrolled memory allocation in the binary Ion stream cursor in Amazon ion-java before 1.12.0 might allow remote actors to cause a denial of service via a crafted Ion binary document containing a declared-length field that causes excessive heap preallocation.

To remediate this issue, users should upgrade to version 1.12.0.

Weakness: CWE-789 (Memory Allocation with Excessive Size Value)

## Which versions are affected by CVE-2026-75935?


## How do I fix CVE-2026-75935?

No fix has been published for CVE-2026-75935 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-75935 being exploited?

There is no known exploitation of CVE-2026-75935 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-75935 and fix it if it is affected.

What it is: CVE-2026-75935 is a high-severity denial of service vulnerability in Amazon Ion Java, published on 18 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-75935 in the wild and no public exploit code.

Affected product: Amazon Ion Java. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-75935/ (Markdown: https://insights.sbomify.com/CVE-2026-75935/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-75935
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-75935
- OSV: https://osv.dev/vulnerability/CVE-2026-75935

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-75935/
Summaries are generated and may contain mistakes; the official description above is the record.
