{"answers":{"affected":"3 open source packages ship an affected version, including mem0ai.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-7597 exists.","fix":"Upgrade mem0ai to 2.0.0b2 or later.","what":"CVE-2026-7597 is a medium-severity unsafe deserialization vulnerability in mem0ai mem0, published on 1 May 2026. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-7597 and fix it if it is affected.\n\nWhat it is: CVE-2026-7597 is a medium-severity unsafe deserialization vulnerability in mem0ai mem0, published on 1 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-7597 exists.\n\nAffected packages and fixed versions:\n- mem0ai (PyPI): affected all versions; fixed in 2.0.0b2\n- mem0ai (PyPI): affected all versions; fixed in 2.0.0b2\n- mem0ai (PyPI): affected all versions; fixed in 2.0.0b2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-7597/ (Markdown: https://insights.sbomify.com/CVE-2026-7597/index.md)","id":"CVE-2026-7597","markdown":"https://insights.sbomify.com/CVE-2026-7597/index.md","name":"CVE-2026-7597","record":{"aliases":["ECHO-2dac-3258-fd8b","GHSA-xqxw-r767-67m7","PYSEC-2026-2636"],"analysis":{"component_type":"library","fix_type":"patch","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Python vector store library","requires_auth":"low_privilege","summary":"Remote attackers can execute arbitrary code via unsafe pickle deserialization in the mem0 vector store library.","user_interaction":"not_required","vuln_class":"deserialization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulDB","cpe":[],"cvss":{"score":5.3,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:P","version":"4.0"},"cwes":[{"id":"CWE-502","name":"Deserialization of Untrusted Data"},{"id":"CWE-20","name":"Improper Input Validation"}],"description":"A vulnerability was found in mem0ai mem0 up to 1.0.11. This affects the function pickle.load/pickle.dump of the file mem0/vector_stores/faiss.py. Performing a manipulation results in deserialization. It is possible to initiate the attack remotely. The exploit has been made public and could be used. The patch is named 62dca096f9236010ca15fea9ba369ba740b86b7a. Applying a patch is the recommended action to fix this issue.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"mem0ai mem0 faiss.py pickle.dump deserialization","id":"CVE-2026-7597","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"deserialization","year":"2026"},"n_packages":3,"n_references":7,"next":{"headline":"libssh2 userauth.c userauth_password integer overflow","id":"CVE-2026-7598"},"packages":[{"ecosystem":"PyPI","fixed":["2.0.0b2"],"introduced":["0"],"last_affected":[],"package":"mem0ai","purl":null,"source":"GHSA-xqxw-r767-67m7"},{"ecosystem":"PyPI","fixed":["2.0.0b2"],"introduced":["0"],"last_affected":[],"package":"mem0ai","purl":"pkg:pypi/mem0ai","source":"GHSA-xqxw-r767-67m7"},{"ecosystem":"PyPI","fixed":["2.0.0b2"],"introduced":["0"],"last_affected":[],"package":"mem0ai","purl":"pkg:pypi/mem0ai","source":"PYSEC-2026-2636"}],"prev":{"headline":"nextlevelbuilder ui-ux-pro-max-skill Slide Generator generate-slide.py data.get cross site scripting","id":"CVE-2026-7596"},"products":["mem0"],"published":"2026-05-01","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-05-05","vendors":["mem0ai"]},"summary":"Remote attackers can execute arbitrary code via unsafe pickle deserialization in the mem0 vector store library.","url":"https://insights.sbomify.com/CVE-2026-7597/"}