# CVE-2026-7597: mem0ai mem0 faiss.py pickle.dump deserialization

> Remote attackers can execute arbitrary code via unsafe pickle deserialization in the mem0 vector store library.

- **Severity:** Medium 5.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 May 2026
- **Updated:** 5 May 2026
- **Also known as:** ECHO-2dac-3258-fd8b, GHSA-xqxw-r767-67m7, PYSEC-2026-2636

## What is CVE-2026-7597?

CVE-2026-7597 is a medium-severity unsafe deserialization vulnerability in mem0ai mem0, published on 1 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

A vulnerability was found in mem0ai mem0 up to 1.0.11. This affects the function pickle.load/pickle.dump of the file mem0/vector_stores/faiss.py. Performing a manipulation results in deserialization. It is possible to initiate the attack remotely. The exploit has been made public and could be used. The patch is named 62dca096f9236010ca15fea9ba369ba740b86b7a. Applying a patch is the recommended action to fix this issue.

Weakness: CWE-502 (Deserialization of Untrusted Data), CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2026-7597?

3 open source packages ship an affected version, including mem0ai.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mem0ai` | PyPI | All versions | 2.0.0b2 |
| `mem0ai` | PyPI | All versions | 2.0.0b2 |
| `mem0ai` | PyPI | All versions | 2.0.0b2 |

## How do I fix CVE-2026-7597?

Upgrade mem0ai to 2.0.0b2 or later.

## Is CVE-2026-7597 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-7597 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-7597 and fix it if it is affected.

What it is: CVE-2026-7597 is a medium-severity unsafe deserialization vulnerability in mem0ai mem0, published on 1 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-7597 exists.

Affected packages and fixed versions:
- mem0ai (PyPI): affected all versions; fixed in 2.0.0b2
- mem0ai (PyPI): affected all versions; fixed in 2.0.0b2
- mem0ai (PyPI): affected all versions; fixed in 2.0.0b2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-7597/ (Markdown: https://insights.sbomify.com/CVE-2026-7597/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-7597
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-7597
- OSV: https://osv.dev/vulnerability/CVE-2026-7597

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-7597/
Summaries are generated and may contain mistakes; the official description above is the record.
