CVE-2026-75975 fast-uri vulnerable to server-side request forgery via malformed IPv6 normalization
An attacker can exploit malformed IPv6 literals in fast-uri to redirect server requests to local or private addresses, bypassing security controls.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-75975?
CVE-2026-75975 is a high-severity server-side request forgery vulnerability in fast-uri, published on 24 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
fast-uri is a URI parser for Node.js. Its custom parser for bracketed IPv6 literals does not validate the complete IPv6 grammar, so invalid trailing text in an authority can be silently discarded and a malformed attacker-controlled host is turned into a different valid IPv6 destination. For example, a bracketed literal with invalid trailing characters is normalized to the unspecified address, which a Node HTTP client then connects to a local service over loopback, and other malformed literals collapse to private-range addresses. No error is set on the parsed result, so an application checking the error field cannot detect the rewrite. An application that normalizes untrusted URLs before outbound requests, redirects, proxy routing, or address-policy enforcement can be redirected to a local or private IPv6 target, giving a server-side request forgery and address-policy bypass primitive. The affected versions are 2.3.1 up to but not including 2.4.5, 3.0.0 up to but not including 3.1.6, and 4.0.0 up to but not including 4.1.3. The issue is fixed in 2.4.5, 3.1.6, and 4.1.3, which validate bracketed IP literals against the full grammar and mark malformed literals as authority errors. Users should upgrade to a patched version.
Which versions are affected by CVE-2026-75975?
6 open source packages ship an affected version, including fast-uri. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
fast-uri npm | From 2.3.1 | 2.4.5 |
fast-uri npm | From 2.3.1 | 2.4.5 |
fast-uri npm | From 3.0.0 | 3.1.6 |
fast-uri npm | From 3.0.0 | 3.1.6 |
fast-uri npm | From 4.0.0 | 4.1.3 |
fast-uri npm | From 4.0.0 | 4.1.3 |
Products include Openjsf Fast-Uri.
How do I fix CVE-2026-75975?
Upgrade fast-uri to a fixed version for your release line: 2.4.5, 3.1.6 or 4.1.3.
Upgrade, and send outbound requests through an allow-list that blocks internal addresses. More about Server-side request forgery.
Is CVE-2026-75975 being exploited?
There is no known exploitation of CVE-2026-75975 in the wild and no public exploit code.
Other vulnerabilities in fast-uri
- CVE-2026-84292 fast-uri vulnerable to authority injection via an unvalidated port in serialize
- CVE-2026-84394 fast-uri vulnerable to host confusion via an unclosed bracket in the URI authority
- CVE-2026-75899 fast-uri vulnerable to server-side request forgery via repeated hostname percent-decoding
- CVE-2026-75931 fast-uri vulnerable to host confusion via skipped IDN canonicalization on scheme-relative references
- CVE-2026-76172 fast-uri vulnerable to host confusion via percent-encoded scheme normalization
Sources
Also known as CLEANSTART-2026-AH49048, CLEANSTART-2026-OS54288, CLEANSTART-2026-UE15220, CLEANSTART-2026-US61275, DEBIAN-CVE-2026-75975, ECHO-2cdf-c60a-7fb1 and 41 more.