# CVE-2026-75975: fast-uri vulnerable to server-side request forgery via malformed IPv6 normalization

> An attacker can exploit malformed IPv6 literals in fast-uri to redirect server requests to local or private addresses, bypassing security controls.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 24 Aug 2026
- **Updated:** 24 Aug 2026
- **Also known as:** CLEANSTART-2026-AH49048, CLEANSTART-2026-OS54288, CLEANSTART-2026-UE15220, CLEANSTART-2026-US61275, DEBIAN-CVE-2026-75975, ECHO-2cdf-c60a-7fb1, GHSA-f65p-4m7j-42xc, MINI-2594-5f9m-982h, MINI-2xhf-mr9x-v23v, MINI-3467-8348-5jf3, MINI-3cgh-jwh7-v3v4, MINI-5wx3-9j7x-qmr4, MINI-5x69-cp56-6gjq, MINI-6cq7-gcx7-hm56, MINI-6f79-chx7-gm69, MINI-8g43-c9r3-8jx6, MINI-8rr8-f899-f7j7, MINI-9869-g6pf-cqv4, MINI-9phj-qvfw-h4p2, MINI-9qf3-f2j6-9jq4, MINI-9xj5-c9wm-4v8v, MINI-cj7f-7ffm-h4mq, MINI-crp4-5qqm-wg5v, MINI-f2rc-wv3f-gqm5, MINI-fgc6-2hx4-9gr8, MINI-fj57-x923-4hq3, MINI-g7pw-h4m7-rfv4, MINI-h6j7-88rq-jw3j, MINI-h9m8-j9v7-73wq, MINI-hh6h-mg2v-g7c5, MINI-hjhh-8m8j-7w66, MINI-j4g2-q757-78fp, MINI-m99c-f493-6w9v, MINI-mq99-4gf9-ch72, MINI-p2wv-xj7m-hhw2, MINI-ppf5-jxh4-9q7p, MINI-pxj2-q294-6rwm, MINI-q3rj-wgjm-7chg, MINI-q8g2-qg7m-73x4, MINI-vvg3-8jp8-rc5q, MINI-w2cv-xr93-6vvm, MINI-wh9q-6c77-wp4q, MINI-xhmm-cf92-82xh, MINI-xpxg-4qqr-g6x8, MINI-xrc7-6qg4-4j6q, ROOT-APP-NPM-CVE-2026-75975, UBUNTU-CVE-2026-75975

## What is CVE-2026-75975?

CVE-2026-75975 is a high-severity server-side request forgery vulnerability in fast-uri, published on 24 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

fast-uri is a URI parser for Node.js. Its custom parser for bracketed IPv6 literals does not validate the complete IPv6 grammar, so invalid trailing text in an authority can be silently discarded and a malformed attacker-controlled host is turned into a different valid IPv6 destination. For example, a bracketed literal with invalid trailing characters is normalized to the unspecified address, which a Node HTTP client then connects to a local service over loopback, and other malformed literals collapse to private-range addresses. No error is set on the parsed result, so an application checking the error field cannot detect the rewrite. An application that normalizes untrusted URLs before outbound requests, redirects, proxy routing, or address-policy enforcement can be redirected to a local or private IPv6 target, giving a server-side request forgery and address-policy bypass primitive. The affected versions are 2.3.1 up to but not including 2.4.5, 3.0.0 up to but not including 3.1.6, and 4.0.0 up to but not including 4.1.3. The issue is fixed in 2.4.5, 3.1.6, and 4.1.3, which validate bracketed IP literals against the full grammar and mark malformed literals as authority errors. Users should upgrade to a patched version.

Weakness: CWE-918 (Server-Side Request Forgery), CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2026-75975?

6 open source packages ship an affected version, including fast-uri. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `fast-uri` | npm | From 2.3.1 | 2.4.5 |
| `fast-uri` | npm | From 2.3.1 | 2.4.5 |
| `fast-uri` | npm | From 3.0.0 | 3.1.6 |
| `fast-uri` | npm | From 3.0.0 | 3.1.6 |
| `fast-uri` | npm | From 4.0.0 | 4.1.3 |
| `fast-uri` | npm | From 4.0.0 | 4.1.3 |

Products: Openjsf Fast-Uri.

## How do I fix CVE-2026-75975?

Upgrade fast-uri to a fixed version for your release line: 2.4.5, 3.1.6 or 4.1.3.

## Is CVE-2026-75975 being exploited?

There is no known exploitation of CVE-2026-75975 in the wild and no public exploit code.

## Other vulnerabilities in fast-uri

- [CVE-2026-84292](https://insights.sbomify.com/CVE-2026-84292/): fast-uri vulnerable to authority injection via an unvalidated port in serialize (high 7.5)
- [CVE-2026-84394](https://insights.sbomify.com/CVE-2026-84394/): fast-uri vulnerable to host confusion via an unclosed bracket in the URI authority (high 7.5)
- [CVE-2026-75899](https://insights.sbomify.com/CVE-2026-75899/): fast-uri vulnerable to server-side request forgery via repeated hostname percent-decoding (high 7.5)
- [CVE-2026-75931](https://insights.sbomify.com/CVE-2026-75931/): fast-uri vulnerable to host confusion via skipped IDN canonicalization on scheme-relative references (high 7.5)
- [CVE-2026-76172](https://insights.sbomify.com/CVE-2026-76172/): fast-uri vulnerable to host confusion via percent-encoded scheme normalization (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-75975 and fix it if it is affected.

What it is: CVE-2026-75975 is a high-severity server-side request forgery vulnerability in fast-uri, published on 24 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-75975 in the wild and no public exploit code.

Affected packages and fixed versions:
- fast-uri (npm): affected from 2.3.1; fixed in 2.4.5
- fast-uri (npm): affected from 2.3.1; fixed in 2.4.5
- fast-uri (npm): affected from 3.0.0; fixed in 3.1.6
- fast-uri (npm): affected from 3.0.0; fixed in 3.1.6
- fast-uri (npm): affected from 4.0.0; fixed in 4.1.3
- fast-uri (npm): affected from 4.0.0; fixed in 4.1.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-75975/ (Markdown: https://insights.sbomify.com/CVE-2026-75975/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-75975
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-75975
- OSV: https://osv.dev/vulnerability/CVE-2026-75975

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-75975/
Summaries are generated and may contain mistakes; the official description above is the record.
