CVE-2026-7601 Open5GS AMF gmm-handler.c denial of service

Medium 5.3 Published Updated

Remote attackers can cause a denial of service in Open5GS AMF by manipulating the reg_type argument in gmm-handler.c.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2026-7601?

CVE-2026-7601 is a medium-severity denial of service vulnerability in Open5GS, published on 2 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

A vulnerability has been found in Open5GS up to 2.7.6. Affected is an unknown function of the file src/amf/gmm-handler.c of the component AMF. The manipulation of the argument reg_type leads to denial of service. The attack is possible to be carried out remotely. Upgrading to version 2.7.7 is able to address this issue. The identifier of the patch is ebc66942b6f8f1fab2d640e71cf4e9f1a423b426. It is advisable to upgrade the affected component.

Weakness: CWE-404

Which versions are affected by CVE-2026-7601?

How do I fix CVE-2026-7601?

No fix has been published for CVE-2026-7601 yet. Limit exposure of the affected software until one is available.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2026-7601 being exploited?

There is no known exploitation of CVE-2026-7601 in the wild and no public exploit code.

Sources

Also known as GHSA-mj36-j6cx-7vw2.

Is CVE-2026-7601 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free