# CVE-2026-7601: Open5GS AMF gmm-handler.c denial of service

> Remote attackers can cause a denial of service in Open5GS AMF by manipulating the reg_type argument in gmm-handler.c.

- **Severity:** Medium 5.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N/E:X`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 2 May 2026
- **Updated:** 4 May 2026
- **Also known as:** GHSA-mj36-j6cx-7vw2

## What is CVE-2026-7601?

CVE-2026-7601 is a medium-severity denial of service vulnerability in Open5GS, published on 2 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

A vulnerability has been found in Open5GS up to 2.7.6. Affected is an unknown function of the file src/amf/gmm-handler.c of the component AMF. The manipulation of the argument reg_type leads to denial of service. The attack is possible to be carried out remotely. Upgrading to version 2.7.7 is able to address this issue. The identifier of the patch is ebc66942b6f8f1fab2d640e71cf4e9f1a423b426. It is advisable to upgrade the affected component.

Weakness: CWE-404 (Improper Resource Shutdown or Release)

## Which versions are affected by CVE-2026-7601?


## How do I fix CVE-2026-7601?

No fix has been published for CVE-2026-7601 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-7601 being exploited?

There is no known exploitation of CVE-2026-7601 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-7601 and fix it if it is affected.

What it is: CVE-2026-7601 is a medium-severity denial of service vulnerability in Open5GS, published on 2 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-7601 in the wild and no public exploit code.

Affected product: Open5GS. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-7601/ (Markdown: https://insights.sbomify.com/CVE-2026-7601/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-7601
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-7601
- OSV: https://osv.dev/vulnerability/CVE-2026-7601

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-7601/
Summaries are generated and may contain mistakes; the official description above is the record.
