CVE-2026-76086 Formie: Integration form-settings action allows SSRF and exfiltration of stored integration credentials
Authenticated attackers can exploit missing permissions to perform SSRF and exfiltrate stored integration credentials in Formie.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-76086?
CVE-2026-76086 is a high-severity server-side request forgery vulnerability in verbb formie, published on 23 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Formie is a Craft CMS plugin for creating forms. Prior to 2.2.23 and 3.1.31, Formie's formie/integrations/form-settings control panel action in IntegrationsController::actionFormSettings is reachable without the required form integration permissions and passes request-supplied settings to a configured integration. An authenticated attacker can replace outbound host properties such as apiUrl while the server uses stored API keys or OAuth tokens, causing non-blind server-side requests to an attacker-controlled or internal host and returning the remote response. This residual flaw remained because the permission gate added in version 3.1.28 excluded the form-settings action. Sites that permit low-privileged or front-end user authentication can therefore expose integration credentials and internal network responses. This issue is fixed in versions 2.2.23 and 3.1.31.
Which versions are affected by CVE-2026-76086?
4 open source packages ship an affected version, including verbb/formie.
| Package | Affected | Fixed in |
|---|---|---|
verbb/formie Packagist | All versions | 2.2.23 |
verbb/formie Packagist | All versions | 2.2.23 |
verbb/formie Packagist | From 3.0.0 | 3.1.31 |
verbb/formie Packagist | From 3.0.0 | 3.1.31 |
How do I fix CVE-2026-76086?
Upgrade verbb/formie to a fixed version for your release line: 2.2.23 or 3.1.31.
Upgrade, and send outbound requests through an allow-list that blocks internal addresses. More about Server-side request forgery.
Is CVE-2026-76086 being exploited?
There is no known exploitation of CVE-2026-76086 in the wild and no public exploit code.
Sources
Also known as GHSA-v3f3-cmj4-cvj9.