# CVE-2026-76098: Mistune has Denial of Service — RecursionError via Excessive Emphasis Markers in Markdown

> Crafted Markdown with excessive emphasis markers causes a RecursionError, crashing the parsing process in the Mistune library.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 24 Aug 2026
- **Updated:** 24 Aug 2026
- **Also known as:** AZL-97956, DEBIAN-CVE-2026-76098, ECHO-47d2-ddd1-74a0, GHSA-6m44-fpc8-c3rq, MINI-x355-jpjp-p4hj, PYSEC-2026-3863, UBUNTU-CVE-2026-76098

## What is CVE-2026-76098?

CVE-2026-76098 is a high-severity denial of service vulnerability in lepture mistune, published on 24 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Mistune is a Python Markdown parser with renderers and plugins. Versions 3.3.0 through 3.3.2 are vulnerable to DoS through deeply nested tokens. HTML rendering creates deeply nested emphasis tokens from consecutive asterisk characters, and recursive rendering in HTMLRenderer.render_token() can exceed Python's recursion limit and raise RecursionError, allowing crafted Markdown to crash a parsing process. This issue is fixed in version 3.3.3

Weakness: CWE-674 (Uncontrolled Recursion)

## Which versions are affected by CVE-2026-76098?

3 open source packages ship an affected version, including mistune.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mistune` | PyPI | From 3.3.0 | 3.3.3 |
| `mistune` | PyPI | From 3.3.0 | 3.3.3 |
| `mistune` | PyPI | From 3.3.0 | 3.3.3 |

## How do I fix CVE-2026-76098?

Upgrade mistune to 3.3.3 or later.

## Is CVE-2026-76098 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-76098 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-76098 and fix it if it is affected.

What it is: CVE-2026-76098 is a high-severity denial of service vulnerability in lepture mistune, published on 24 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-76098 exists.

Affected packages and fixed versions:
- mistune (PyPI): affected from 3.3.0; fixed in 3.3.3
- mistune (PyPI): affected from 3.3.0; fixed in 3.3.3
- mistune (PyPI): affected from 3.3.0; fixed in 3.3.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-76098/ (Markdown: https://insights.sbomify.com/CVE-2026-76098/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-76098
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-76098
- OSV: https://osv.dev/vulnerability/CVE-2026-76098

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-76098/
Summaries are generated and may contain mistakes; the official description above is the record.
