# CVE-2026-76169: fastify vulnerable to authentication bypass via malformed URLs reaching encapsulated not-found handlers

> An unauthenticated attacker can bypass authentication hooks to read protected responses from encapsulated not-found handlers via malformed URLs.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 4 Sep 2026
- **Updated:** 4 Sep 2026
- **Also known as:** CLSA-2026-1790863084, CLSA-2026-1790871227, CLSA-2026-1790889495, GHSA-p68q-wchp-6fh7, MINI-v23q-6ffp-9r2f

## What is CVE-2026-76169?

CVE-2026-76169 is a high-severity authentication bypass vulnerability in fastify, published on 4 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

fastify versions >= 4.0.0 and before 5.12.2 can route a malformed URL sent under one plugin prefix to the custom not-found handler of a different sibling plugin, and invoke it without the preHandler hook declared for that handler. The internal not-found router for encapsulated handlers dispatches malformed paths through a single shared handler pointer before URL decoding, ignoring the prefix and skipping the selected handler's normal lifecycle. An unauthenticated attacker can therefore reach an authentication-protected private fallback through an unrelated public prefix and read its full response, bypassing the authentication hook and breaking prefix encapsulation. Users should upgrade to fastify 5.12.2 or later.

Weakness: CWE-288 (Authentication Bypass Using an Alternate Path or Channel)

## Which versions are affected by CVE-2026-76169?

2 open source packages ship an affected version, including fastify. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `fastify` | npm | From 4.0.0 | 5.12.2 |
| `fastify` | npm | From 4.0.0 | 5.12.2 |

Products: Fastify Fastify.

## How do I fix CVE-2026-76169?

Upgrade fastify to 5.12.2 or later.

## Is CVE-2026-76169 being exploited?

There is no known exploitation of CVE-2026-76169 in the wild and no public exploit code.

## Other vulnerabilities in fastify

- [CVE-2026-84504](https://insights.sbomify.com/CVE-2026-84504/): fastify vulnerable to request body replacement via an async validation result collision (high 8.1)
- [CVE-2026-84428](https://insights.sbomify.com/CVE-2026-84428/): fastify vulnerable to header validation bypass via incomplete schema case normalization (high 7.5)
- [CVE-2026-84469](https://insights.sbomify.com/CVE-2026-84469/): fastify vulnerable to request validation bypass via skipped boolean false schemas (high 7.5)
- [CVE-2026-33806](https://insights.sbomify.com/CVE-2026-33806/): fastify vulnerable to Body Schema Validation Bypass via Leading Space in Content-Type Header (high 7.5)
- [CVE-2026-25223](https://insights.sbomify.com/CVE-2026-25223/): Fastify's Content-Type header tab character allows body validation bypass (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-76169 and fix it if it is affected.

What it is: CVE-2026-76169 is a high-severity authentication bypass vulnerability in fastify, published on 4 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-76169 in the wild and no public exploit code.

Affected packages and fixed versions:
- fastify (npm): affected from 4.0.0; fixed in 5.12.2
- fastify (npm): affected from 4.0.0; fixed in 5.12.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-76169/ (Markdown: https://insights.sbomify.com/CVE-2026-76169/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-76169
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-76169
- OSV: https://osv.dev/vulnerability/CVE-2026-76169

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-76169/
Summaries are generated and may contain mistakes; the official description above is the record.
