CVE-2026-76172 fast-uri vulnerable to host confusion via percent-encoded scheme normalization
Attackers can bypass host allowlists and trigger SSRF or redirects by exploiting scheme normalization flaws in the fast-uri Node.js library.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-76172?
CVE-2026-76172 is a high-severity server-side request forgery vulnerability in fast-uri, published on 24 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
fast-uri is a URI parser for Node.js. During parsing it runs a legacy decoding pass over the scheme component and never re-escapes the result, and serialization writes the scheme back out verbatim, unlike the host component which is re-escaped. As a result an input whose scheme carries percent-encoded slashes parses as a scheme with no authority, so the parsed host and error are both undefined, yet resolving or normalizing that same input emits a network-path reference whose authority is attacker-chosen and re-parses to that host. An application that allowlists on the parsed host, or treats a reference with no authority as safe to resolve against its base, gets the opposite of what it checked, giving an off-site redirect, server-side request forgery, or address-policy bypass. The legacy decoder also expands non-standard escape forms, widening the issue past upstream filters, and control characters in the scheme can reach the output as raw carriage return and line feed. The affected versions are 2.3.1 up to but not including 2.4.5, 3.0.0 up to but not including 3.1.6, and 4.0.0 up to but not including 4.1.3. The issue is fixed in 2.4.5, 3.1.6, and 4.1.3, which reject a scheme that is not valid after decoding. Users should upgrade to a patched version.
Weakness: CWE-177
Which versions are affected by CVE-2026-76172?
6 open source packages ship an affected version, including fast-uri. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
fast-uri npm | From 2.3.1 | 2.4.5 |
fast-uri npm | From 2.3.1 | 2.4.5 |
fast-uri npm | From 3.0.0 | 3.1.6 |
fast-uri npm | From 3.0.0 | 3.1.6 |
fast-uri npm | From 4.0.0 | 4.1.3 |
fast-uri npm | From 4.0.0 | 4.1.3 |
Products include Openjsf Fast-Uri.
How do I fix CVE-2026-76172?
Upgrade fast-uri to a fixed version for your release line: 2.4.5, 3.1.6 or 4.1.3.
Upgrade, and send outbound requests through an allow-list that blocks internal addresses. More about Server-side request forgery.
Is CVE-2026-76172 being exploited?
There is no known exploitation of CVE-2026-76172 in the wild and no public exploit code.
Other vulnerabilities in fast-uri
- CVE-2026-84292 fast-uri vulnerable to authority injection via an unvalidated port in serialize
- CVE-2026-84394 fast-uri vulnerable to host confusion via an unclosed bracket in the URI authority
- CVE-2026-75899 fast-uri vulnerable to server-side request forgery via repeated hostname percent-decoding
- CVE-2026-75931 fast-uri vulnerable to host confusion via skipped IDN canonicalization on scheme-relative references
- CVE-2026-75975 fast-uri vulnerable to server-side request forgery via malformed IPv6 normalization
Sources
Also known as CLEANSTART-2026-LZ46216, CLEANSTART-2026-OU85538, CLEANSTART-2026-WM48564, CLEANSTART-2026-YB63066, DEBIAN-CVE-2026-76172, ECHO-5fe8-6e62-8727 and 41 more.