# CVE-2026-76172: fast-uri vulnerable to host confusion via percent-encoded scheme normalization

> Attackers can bypass host allowlists and trigger SSRF or redirects by exploiting scheme normalization flaws in the fast-uri Node.js library.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 24 Aug 2026
- **Updated:** 24 Aug 2026
- **Also known as:** CLEANSTART-2026-LZ46216, CLEANSTART-2026-OU85538, CLEANSTART-2026-WM48564, CLEANSTART-2026-YB63066, DEBIAN-CVE-2026-76172, ECHO-5fe8-6e62-8727, GHSA-jqff-g426-hqxp, MINI-39h2-9cxv-4cjf, MINI-3fq6-c328-vfm5, MINI-3hpm-4rmg-pfrq, MINI-3v47-gj4v-2gxq, MINI-45gw-6mf2-mphj, MINI-4m3m-f4fw-gwj8, MINI-6jj5-9f7c-vcqw, MINI-6p22-wvmv-pc2j, MINI-7363-wc82-97fv, MINI-7p9g-q4h7-xwvf, MINI-84g7-7754-55jw, MINI-84xr-2fvg-c7ww, MINI-8p35-q35v-9624, MINI-9993-7qgg-c868, MINI-9rrj-g7hh-8jg7, MINI-ffgh-pcc7-v5jw, MINI-g4j2-fg6r-r5w7, MINI-gc28-6vvf-cf2m, MINI-gh7g-6mh2-cq39, MINI-h9fx-fffq-m8hw, MINI-hh7v-vhhh-r839, MINI-hq4p-6c4r-7hv7, MINI-j8h7-4mx3-mg64, MINI-jgwm-p4v2-v7hh, MINI-jx62-52jc-rv2v, MINI-m2mq-mgv5-mq9h, MINI-m6f8-mx88-c837, MINI-m6f9-p5q9-7mrv, MINI-p4p3-9c9r-6fhh, MINI-pffr-2wq4-p9vx, MINI-pj5q-8r9j-vh4r, MINI-v42v-xhgg-8f82, MINI-vf64-x62q-954m, MINI-w85m-vrqx-g93w, MINI-wmh4-mgxr-w2j3, MINI-wp9g-m857-j59w, MINI-xmp5-qv8m-c39v, MINI-xwq9-3hgc-8xj6, ROOT-APP-NPM-CVE-2026-76172, UBUNTU-CVE-2026-76172

## What is CVE-2026-76172?

CVE-2026-76172 is a high-severity server-side request forgery vulnerability in fast-uri, published on 24 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

fast-uri is a URI parser for Node.js. During parsing it runs a legacy decoding pass over the scheme component and never re-escapes the result, and serialization writes the scheme back out verbatim, unlike the host component which is re-escaped. As a result an input whose scheme carries percent-encoded slashes parses as a scheme with no authority, so the parsed host and error are both undefined, yet resolving or normalizing that same input emits a network-path reference whose authority is attacker-chosen and re-parses to that host. An application that allowlists on the parsed host, or treats a reference with no authority as safe to resolve against its base, gets the opposite of what it checked, giving an off-site redirect, server-side request forgery, or address-policy bypass. The legacy decoder also expands non-standard escape forms, widening the issue past upstream filters, and control characters in the scheme can reach the output as raw carriage return and line feed. The affected versions are 2.3.1 up to but not including 2.4.5, 3.0.0 up to but not including 3.1.6, and 4.0.0 up to but not including 4.1.3. The issue is fixed in 2.4.5, 3.1.6, and 4.1.3, which reject a scheme that is not valid after decoding. Users should upgrade to a patched version.

Weakness: CWE-177 (Improper Handling of URL Encoding (Hex Encoding))

## Which versions are affected by CVE-2026-76172?

6 open source packages ship an affected version, including fast-uri. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `fast-uri` | npm | From 2.3.1 | 2.4.5 |
| `fast-uri` | npm | From 2.3.1 | 2.4.5 |
| `fast-uri` | npm | From 3.0.0 | 3.1.6 |
| `fast-uri` | npm | From 3.0.0 | 3.1.6 |
| `fast-uri` | npm | From 4.0.0 | 4.1.3 |
| `fast-uri` | npm | From 4.0.0 | 4.1.3 |

Products: Openjsf Fast-Uri.

## How do I fix CVE-2026-76172?

Upgrade fast-uri to a fixed version for your release line: 2.4.5, 3.1.6 or 4.1.3.

## Is CVE-2026-76172 being exploited?

There is no known exploitation of CVE-2026-76172 in the wild and no public exploit code.

## Other vulnerabilities in fast-uri

- [CVE-2026-84292](https://insights.sbomify.com/CVE-2026-84292/): fast-uri vulnerable to authority injection via an unvalidated port in serialize (high 7.5)
- [CVE-2026-84394](https://insights.sbomify.com/CVE-2026-84394/): fast-uri vulnerable to host confusion via an unclosed bracket in the URI authority (high 7.5)
- [CVE-2026-75899](https://insights.sbomify.com/CVE-2026-75899/): fast-uri vulnerable to server-side request forgery via repeated hostname percent-decoding (high 7.5)
- [CVE-2026-75931](https://insights.sbomify.com/CVE-2026-75931/): fast-uri vulnerable to host confusion via skipped IDN canonicalization on scheme-relative references (high 7.5)
- [CVE-2026-75975](https://insights.sbomify.com/CVE-2026-75975/): fast-uri vulnerable to server-side request forgery via malformed IPv6 normalization (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-76172 and fix it if it is affected.

What it is: CVE-2026-76172 is a high-severity server-side request forgery vulnerability in fast-uri, published on 24 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-76172 in the wild and no public exploit code.

Affected packages and fixed versions:
- fast-uri (npm): affected from 2.3.1; fixed in 2.4.5
- fast-uri (npm): affected from 2.3.1; fixed in 2.4.5
- fast-uri (npm): affected from 3.0.0; fixed in 3.1.6
- fast-uri (npm): affected from 3.0.0; fixed in 3.1.6
- fast-uri (npm): affected from 4.0.0; fixed in 4.1.3
- fast-uri (npm): affected from 4.0.0; fixed in 4.1.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-76172/ (Markdown: https://insights.sbomify.com/CVE-2026-76172/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-76172
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-76172
- OSV: https://osv.dev/vulnerability/CVE-2026-76172

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-76172/
Summaries are generated and may contain mistakes; the official description above is the record.
