CVE-2026-76183 Apache Tomcat: Bypass of security constraints for WebSocket endpoints
Attackers can bypass security constraints for WebSocket endpoints in Apache Tomcat, allowing unauthorized access to protected resources.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-76183?
CVE-2026-76183 is a critical authentication bypass vulnerability in Apache Tomcat, published on 23 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Authentication Bypass by Alternate Name vulnerability in Apache Tomcat allowed the security constraints for any WebSocket endpoint to be bypassed.
This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.25, from 10.1.0-M1 through 10.1.59, from 9.0.0.M1 through 9.0.121.
The following versions were EOS at the time the CVE was created but are known to be affected: from 8.5.0 through 8.5.100, from 7.0.43 through 7.0.109. Other unsupported versions may also be affected.
Users are recommended to upgrade to version 11.0.26, 10.1.60 or 9.0.122, which fix the issue.
Weakness: CWE-289
Which versions are affected by CVE-2026-76183?
1 open source package ship an affected version, including tomcat.
| Package | Affected | Fixed in |
|---|---|---|
tomcat Bitnami | All versions | 9.0.45, 10.1.60, 11.0.26, 9.0.122 |
How do I fix CVE-2026-76183?
Upgrade tomcat to a fixed version for your release line: 9.0.45, 10.1.60, 11.0.26 or 9.0.122.
Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.
Is CVE-2026-76183 being exploited?
There is no known exploitation of CVE-2026-76183 in the wild and no public exploit code.
Public exploit code: 1 proofs of concept on GitHub.
Sources
Also known as BIT-tomcat-2026-76183, DEBIAN-CVE-2026-76183, GHSA-q4fc-3vv4-fh24, MINI-3vh4-mfc9-pcq6, MINI-cv28-r67x-7q3v, MINI-r7gv-vwmh-cxgr and 1 more.