{"answers":{"affected":"1 open source package ship an affected version, including tomcat.","exploited":"There is no known exploitation of CVE-2026-76183 in the wild and no public exploit code.","fix":"Upgrade tomcat to a fixed version for your release line: 9.0.45, 10.1.60, 11.0.26 or 9.0.122.","what":"CVE-2026-76183 is a critical authentication bypass vulnerability in Apache Tomcat, published on 23 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-76183 and fix it if it is affected.\n\nWhat it is: CVE-2026-76183 is a critical authentication bypass vulnerability in Apache Tomcat, published on 23 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-76183 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- tomcat (Bitnami): affected all versions; fixed in 9.0.45, 10.1.60, 11.0.26, 9.0.122\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-76183/ (Markdown: https://insights.sbomify.com/CVE-2026-76183/index.md)","id":"CVE-2026-76183","markdown":"https://insights.sbomify.com/CVE-2026-76183/index.md","name":"CVE-2026-76183","record":{"aliases":["BIT-tomcat-2026-76183","DEBIAN-CVE-2026-76183","GHSA-q4fc-3vv4-fh24","MINI-3vh4-mfc9-pcq6","MINI-cv28-r67x-7q3v","MINI-r7gv-vwmh-cxgr","UBUNTU-CVE-2026-76183"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Apache Tomcat","requires_auth":"none","summary":"Attackers can bypass security constraints for WebSocket endpoints in Apache Tomcat, allowing unauthorized access to protected resources.","user_interaction":"not_required","vuln_class":"auth_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[],"cvss":{"score":9.8,"severity":"critical","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-289","name":"Authentication Bypass by Alternate Name"}],"description":"Authentication Bypass by Alternate Name vulnerability in Apache Tomcat allowed the security constraints for any WebSocket endpoint to be bypassed.\n\nThis issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.25, from 10.1.0-M1 through 10.1.59, from 9.0.0.M1 through 9.0.121.\n\nThe following versions were EOS at the time the CVE was created but are \nknown to be affected: from 8.5.0 through 8.5.100, from 7.0.43 through 7.0.109. Other unsupported versions may also be affected.\n\nUsers are recommended to upgrade to version 11.0.26, 10.1.60 or 9.0.122, which fix the issue.","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":"2026-10-23","github_poc":1,"max_poc_stars":1,"metasploit":0,"nuclei":0,"refs":[{"date":"2026-10-23T16:30:46Z","kind":"github_poc","ref":"https://github.com/Ethen1212/tomcat-CVE-2026-76183","stars":1,"title":"Apache Tomcat WebSocket security constraint bypass (CVE-2026-76183) reproduction"}],"tier":"poc_unverified"},"has_fix":true,"headline":"Apache Tomcat: Bypass of security constraints for WebSocket endpoints","id":"CVE-2026-76183","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":null,"products":[],"type":"auth_bypass","year":"2026"},"n_packages":1,"n_references":1,"next":{"headline":"Information disclosure in Eclipse Jetty","id":"CVE-2026-76184"},"packages":[{"ecosystem":"Bitnami","fixed":["9.0.45","10.1.60","11.0.26","9.0.122"],"introduced":["0","10.1.0","11.0.0","9.0.0"],"last_affected":[],"package":"tomcat","purl":"pkg:bitnami/tomcat","source":"BIT-tomcat-2026-76183"}],"prev":{"headline":"Other in Eclipse Jetty","id":"CVE-2026-76182"},"products":["Apache Tomcat"],"published":"2026-09-23","related":[],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"open","licence":"CC0","name":"PoC-in-GitHub"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-09-30","vendors":["Apache Software Foundation"]},"summary":"Attackers can bypass security constraints for WebSocket endpoints in Apache Tomcat, allowing unauthorized access to protected resources.","url":"https://insights.sbomify.com/CVE-2026-76183/"}