# CVE-2026-76217: GitPython before 3.1.58 Arbitrary File Read via pathspec-from-file

> Attackers can read arbitrary files by injecting pathspec options into GitPython commands, exposing sensitive data to anyone using the library.

- **Severity:** High 7.1 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 Aug 2026
- **Updated:** 8 Oct 2026
- **Also known as:** DEBIAN-CVE-2026-76217, ECHO-968b-262a-8d39, GHSA-hh9p-6wh2-4mfc, MINI-8xjg-r739-2m57, MINI-mcfq-5f5m-qchm, MINI-q368-cw7g-925p, MINI-rwmx-h6mj-gpcj, MINI-x9jr-g5g2-fw8v, OESA-2026-3523, OESA-2026-3524, PYSEC-2026-3841, UBUNTU-CVE-2026-76217

## What is CVE-2026-76217?

CVE-2026-76217 is a high-severity path traversal vulnerability in gitpython-developers GitPython, published on 19 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

GitPython versions before 3.1.58 fail to validate options passed to git rm and git checkout commands in IndexFile.remove() and Head.checkout(). Attackers can supply --pathspec-from-file and --pathspec-file-nul parameters to read arbitrary files accessible to the process, with full file contents returned in GitCommandError.stderr.

Weakness: CWE-73 (External Control of File Name or Path)

## Which versions are affected by CVE-2026-76217?

3 open source packages ship an affected version, including gitpython and GitPython. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `gitpython` | PyPI | All versions | 3.1.58 |
| `gitpython` | PyPI | All versions | 3.1.58 |
| `GitPython` | PyPI | All versions | 3.1.58 |

Products: Gitpython Project Gitpython.

## How do I fix CVE-2026-76217?

Upgrade gitpython to 3.1.58 or later.

## Is CVE-2026-76217 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-76217 exists.

## Other vulnerabilities in gitpython-developers GitPython

- [CVE-2023-40267](https://insights.sbomify.com/CVE-2023-40267/): GitPython vulnerable to remote code execution due to insufficient sanitization of input arguments (critical 9.8)
- [CVE-2026-78676](https://insights.sbomify.com/CVE-2026-78676/): GitPython before 3.1.59 Remote Code Execution via Config Injection (critical 9.3)
- [CVE-2026-67324](https://insights.sbomify.com/CVE-2026-67324/): GitPython 3.1.50 Authentication Bypass via Joined Short Options (critical 9.3)
- [CVE-2026-42215](https://insights.sbomify.com/CVE-2026-42215/): GitPython: Command injection via Git options bypass (high 8.8)
- [CVE-2026-87817](https://insights.sbomify.com/CVE-2026-87817/): GitPython before 3.1.60 Remote Code Execution via Git Directory Impersonation (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-76217 and fix it if it is affected.

What it is: CVE-2026-76217 is a high-severity path traversal vulnerability in gitpython-developers GitPython, published on 19 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-76217 exists.

Affected packages and fixed versions:
- gitpython (PyPI): affected all versions; fixed in 3.1.58
- gitpython (PyPI): affected all versions; fixed in 3.1.58
- GitPython (PyPI): affected all versions; fixed in 3.1.58

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-76217/ (Markdown: https://insights.sbomify.com/CVE-2026-76217/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-76217
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-76217
- OSV: https://osv.dev/vulnerability/CVE-2026-76217

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-76217/
Summaries are generated and may contain mistakes; the official description above is the record.
