# CVE-2026-76218: GitPython before 3.1.58 Remote Code Execution via Repo.init

> Attackers can execute arbitrary code by supplying malicious git hooks via the template parameter in Repo.init.

- **Severity:** High 7.7 (`CVSS:4.0/AV:N/AC:H/AT:P/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 Aug 2026
- **Updated:** 8 Oct 2026
- **Also known as:** DEBIAN-CVE-2026-76218, ECHO-b3b9-d62b-b7bc, GHSA-9rj7-rf2p-w77r, MINI-659r-hwhv-h7x5, MINI-jw9p-8fxv-qg89, MINI-q425-9cxm-h29j, MINI-w34j-878r-mc77, MINI-wx9m-v48f-246f, PYSEC-2026-3840, ROOT-APP-PYPI-CVE-2026-76218, ROOT-APP-PYPI-GHSA-9rj7-rf2p-w77r, UBUNTU-CVE-2026-76218

## What is CVE-2026-76218?

CVE-2026-76218 is a high-severity command injection vulnerability in gitpython-developers GitPython, published on 19 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

GitPython before 3.1.58 contains a remote code execution vulnerability in Repo.init that forwards unsafe git options without validation. Attackers can supply a template parameter pointing to a directory with malicious git hooks that execute arbitrary code when git operations are performed on the initialized repository.

Weakness: CWE-88 (Improper Neutralization of Argument Delimiters in a Command)

## Which versions are affected by CVE-2026-76218?

3 open source packages ship an affected version, including gitpython and GitPython. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `gitpython` | PyPI | All versions | 3.1.58 |
| `gitpython` | PyPI | All versions | 3.1.58 |
| `GitPython` | PyPI | All versions | 3.1.58 |

Products: Gitpython Project Gitpython.

## How do I fix CVE-2026-76218?

Upgrade gitpython to 3.1.58 or later.

## Is CVE-2026-76218 being exploited?

There is no known exploitation of CVE-2026-76218 in the wild and no public exploit code.

## Other vulnerabilities in gitpython-developers GitPython

- [CVE-2023-40267](https://insights.sbomify.com/CVE-2023-40267/): GitPython vulnerable to remote code execution due to insufficient sanitization of input arguments (critical 9.8)
- [CVE-2026-78676](https://insights.sbomify.com/CVE-2026-78676/): GitPython before 3.1.59 Remote Code Execution via Config Injection (critical 9.3)
- [CVE-2026-67324](https://insights.sbomify.com/CVE-2026-67324/): GitPython 3.1.50 Authentication Bypass via Joined Short Options (critical 9.3)
- [CVE-2026-42215](https://insights.sbomify.com/CVE-2026-42215/): GitPython: Command injection via Git options bypass (high 8.8)
- [CVE-2026-87817](https://insights.sbomify.com/CVE-2026-87817/): GitPython before 3.1.60 Remote Code Execution via Git Directory Impersonation (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-76218 and fix it if it is affected.

What it is: CVE-2026-76218 is a high-severity command injection vulnerability in gitpython-developers GitPython, published on 19 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-76218 in the wild and no public exploit code.

Affected packages and fixed versions:
- gitpython (PyPI): affected all versions; fixed in 3.1.58
- gitpython (PyPI): affected all versions; fixed in 3.1.58
- GitPython (PyPI): affected all versions; fixed in 3.1.58

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-76218/ (Markdown: https://insights.sbomify.com/CVE-2026-76218/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-76218
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-76218
- OSV: https://osv.dev/vulnerability/CVE-2026-76218

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-76218/
Summaries are generated and may contain mistakes; the official description above is the record.
