# CVE-2026-76221: GitPython before 3.1.58 Config Injection via option-name

> Attackers can inject malicious git-config directives to execute arbitrary commands via core.sshCommand or core.hooksPath in GitPython.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 Aug 2026
- **Updated:** 8 Oct 2026
- **Also known as:** CLSA-2026-1787219647, DEBIAN-CVE-2026-76221, ECHO-2c16-7ddc-9a15, ECHO-9a71-300c-8276, GHSA-78pq-g4m8-fx2c, GHSA-jm78-9fvv-mhgr, MINI-3r35-53c2-g83j, MINI-7qxj-wvgx-pmj3, MINI-gvw5-8x4p-f5jh, MINI-jw86-x58w-rgg5, MINI-w8jq-jw56-hp9p, PYSEC-2026-3783, ROOT-APP-PYPI-GHSA-jm78-9fvv-mhgr, UBUNTU-CVE-2026-76221

## What is CVE-2026-76221?

CVE-2026-76221 is a high-severity command injection vulnerability in gitpython-developers GitPython, published on 19 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

GitPython before 3.1.58 contains a config-name injection vulnerability in the option-name validator that allows attackers to forge arbitrary git-config directives by injecting equals signs, hash symbols, and whitespace into option names. Attackers can inject malicious option names like 'sshCommand = touch /tmp/RCE #' to execute arbitrary commands via core.sshCommand or core.hooksPath on the next git operation.

Weakness: CWE-74 (Improper Neutralization of Special Elements in Output Used by a Downstream Component)

## Which versions are affected by CVE-2026-76221?

3 open source packages ship an affected version, including gitpython and GitPython. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `gitpython` | PyPI | All versions | 3.1.58 |
| `gitpython` | PyPI | All versions | 3.1.58 |
| `GitPython` | PyPI | All versions | 3.1.58 |

Products: Gitpython Project Gitpython.

## How do I fix CVE-2026-76221?

Upgrade gitpython to 3.1.58 or later.

## Is CVE-2026-76221 being exploited?

There is no known exploitation of CVE-2026-76221 in the wild and no public exploit code.

## Other vulnerabilities in gitpython-developers GitPython

- [CVE-2023-40267](https://insights.sbomify.com/CVE-2023-40267/): GitPython vulnerable to remote code execution due to insufficient sanitization of input arguments (critical 9.8)
- [CVE-2026-78676](https://insights.sbomify.com/CVE-2026-78676/): GitPython before 3.1.59 Remote Code Execution via Config Injection (critical 9.3)
- [CVE-2026-67324](https://insights.sbomify.com/CVE-2026-67324/): GitPython 3.1.50 Authentication Bypass via Joined Short Options (critical 9.3)
- [CVE-2026-42215](https://insights.sbomify.com/CVE-2026-42215/): GitPython: Command injection via Git options bypass (high 8.8)
- [CVE-2026-87817](https://insights.sbomify.com/CVE-2026-87817/): GitPython before 3.1.60 Remote Code Execution via Git Directory Impersonation (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-76221 and fix it if it is affected.

What it is: CVE-2026-76221 is a high-severity command injection vulnerability in gitpython-developers GitPython, published on 19 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-76221 in the wild and no public exploit code.

Affected packages and fixed versions:
- gitpython (PyPI): affected all versions; fixed in 3.1.58
- gitpython (PyPI): affected all versions; fixed in 3.1.58
- GitPython (PyPI): affected all versions; fixed in 3.1.58

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-76221/ (Markdown: https://insights.sbomify.com/CVE-2026-76221/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-76221
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-76221
- OSV: https://osv.dev/vulnerability/CVE-2026-76221

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-76221/
Summaries are generated and may contain mistakes; the official description above is the record.
