# CVE-2026-76222: GitPython before 3.1.58 Path Traversal via .gitmodules Submodule Name

> Attackers can create arbitrary files outside the intended directory by exploiting path traversal in GitPython's submodule name validation.

- **Severity:** High 8.4 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:H/VA:L/SC:N/SI:H/SA:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 19 Aug 2026
- **Updated:** 8 Oct 2026
- **Also known as:** CLSA-2026-1787224571, DEBIAN-CVE-2026-76222, ECHO-bdb5-1b58-8a9f, GHSA-hmq2-w58f-27jc, MINI-2644-79v2-p234, MINI-5ch6-pxmw-5c4w, MINI-6hwc-9wx5-h6jm, MINI-8pxv-wpcg-c7jh, MINI-xm23-p7jr-jcgc, PYSEC-2026-3784, ROOT-APP-PYPI-CVE-2026-76222, ROOT-APP-PYPI-GHSA-hmq2-w58f-27jc, UBUNTU-CVE-2026-76222

## What is CVE-2026-76222?

CVE-2026-76222 is a high-severity path traversal vulnerability in gitpython-developers GitPython, published on 19 Aug 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

GitPython before 3.1.58 fails to validate submodule names from .gitmodules files, allowing attackers to create Git repositories at arbitrary filesystem paths outside the intended clone directory. Attackers can craft malicious repositories with traversal sequences in submodule names that GitPython processes during submodule initialization, creating attacker-controlled Git repositories at escaped filesystem locations.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2026-76222?

3 open source packages ship an affected version, including gitpython and GitPython. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `gitpython` | PyPI | All versions | 3.1.58 |
| `gitpython` | PyPI | All versions | 3.1.58 |
| `GitPython` | PyPI | All versions | 3.1.58 |

Products: Gitpython Project Gitpython.

## How do I fix CVE-2026-76222?

Upgrade gitpython to 3.1.58 or later.

## Is CVE-2026-76222 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-76222 exists.

## Other vulnerabilities in gitpython-developers GitPython

- [CVE-2023-40267](https://insights.sbomify.com/CVE-2023-40267/): GitPython vulnerable to remote code execution due to insufficient sanitization of input arguments (critical 9.8)
- [CVE-2026-78676](https://insights.sbomify.com/CVE-2026-78676/): GitPython before 3.1.59 Remote Code Execution via Config Injection (critical 9.3)
- [CVE-2026-67324](https://insights.sbomify.com/CVE-2026-67324/): GitPython 3.1.50 Authentication Bypass via Joined Short Options (critical 9.3)
- [CVE-2026-42215](https://insights.sbomify.com/CVE-2026-42215/): GitPython: Command injection via Git options bypass (high 8.8)
- [CVE-2026-87817](https://insights.sbomify.com/CVE-2026-87817/): GitPython before 3.1.60 Remote Code Execution via Git Directory Impersonation (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-76222 and fix it if it is affected.

What it is: CVE-2026-76222 is a high-severity path traversal vulnerability in gitpython-developers GitPython, published on 19 Aug 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-76222 exists.

Affected packages and fixed versions:
- gitpython (PyPI): affected all versions; fixed in 3.1.58
- gitpython (PyPI): affected all versions; fixed in 3.1.58
- GitPython (PyPI): affected all versions; fixed in 3.1.58

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-76222/ (Markdown: https://insights.sbomify.com/CVE-2026-76222/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-76222
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-76222
- OSV: https://osv.dev/vulnerability/CVE-2026-76222

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-76222/
Summaries are generated and may contain mistakes; the official description above is the record.
