# CVE-2026-76223: ArcadeDB before 26.8.1 Permission Bypass via DEFINE FUNCTION

> Attackers with database access can bypass permission checks to modify existing function libraries, potentially escalating privileges or tampering with logic.

- **Severity:** High 7.1 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:H/VA:L/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 19 Aug 2026
- **Updated:** 19 Aug 2026
- **Also known as:** GHSA-p32w-fr4c-xp93, GHSA-rv64-62hr-wv2p

## What is CVE-2026-76223?

CVE-2026-76223 is a high-severity missing authorization vulnerability in ArcadeData arcadedb, published on 19 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

ArcadeDB (com.arcadedb) versions 26.7.3 and earlier fail to enforce the UPDATE_SCHEMA permission check when a DEFINE FUNCTION statement targets an already-existing function library. A user with only database access can add or overwrite SQL or Cypher functions in an existing library and persist the change, enabling tampering with admin-defined function logic. The issue is fixed in 26.8.1. (JavaScript functions still trigger the UPDATE_SECURITY check and are not affected.)

Weakness: CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2026-76223?


## How do I fix CVE-2026-76223?

No fix has been published for CVE-2026-76223 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-76223 being exploited?

There is no known exploitation of CVE-2026-76223 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-76223 and fix it if it is affected.

What it is: CVE-2026-76223 is a high-severity missing authorization vulnerability in ArcadeData arcadedb, published on 19 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-76223 in the wild and no public exploit code.

Affected product: ArcadeData arcadedb. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-76223/ (Markdown: https://insights.sbomify.com/CVE-2026-76223/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-76223
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-76223
- OSV: https://osv.dev/vulnerability/CVE-2026-76223

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-76223/
Summaries are generated and may contain mistakes; the official description above is the record.
