# CVE-2026-76227: Renovate 42.68.1 before 42.96.3 and 43.0.0 before 43.4.4 Environment Variable Exposure

> Attackers can exfiltrate secrets from environment variables because child processes inherit all variables without restriction.

- **Severity:** Medium 6.8 (`CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 19 Aug 2026
- **Updated:** 8 Oct 2026
- **Also known as:** CLEANSTART-2026-BQ28777, GHSA-8wc6-vgrq-x6cf, GHSA-p44v-39mg-jgrj

## What is CVE-2026-76227?

CVE-2026-76227 is a medium-severity vulnerability in mend renovate, published on 19 Aug 2026. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Renovate versions from 42.68.1 before 42.96.3 and from 43.0.0 before 43.4.4, including the renovate/renovate Docker images, and Mend Renovate CE/EE images (renovate-ce, renovate-ee-server, renovate-ee-worker) from 13.3.0 before 13.6.0, fail to restrict environment variables to an allowlist when spawning child processes. As a result, child processes (e.g. npm install, postUpgradeTasks, postUpdateOptions) gain full access to all environment variables of the Renovate process, allowing insider or outside attackers to exfiltrate secrets accessible to the Renovate deployment.

Weakness: CWE-526 (Cleartext Storage of Sensitive Information in an Environment Variable)

## Which versions are affected by CVE-2026-76227?

4 open source packages ship an affected version, including renovate.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `renovate` | npm | From 42.68.1 | 42.96.3 |
| `renovate` | npm | From 42.68.1 | 42.96.3 |
| `renovate` | npm | From 43.0.0 | 43.4.4 |
| `renovate` | npm | From 43.0.0 | 43.4.4 |

## How do I fix CVE-2026-76227?

Upgrade renovate to a fixed version for your release line: 42.96.3 or 43.4.4.

## Is CVE-2026-76227 being exploited?

There is no known exploitation of CVE-2026-76227 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-76227 and fix it if it is affected.

What it is: CVE-2026-76227 is a medium-severity vulnerability in mend renovate, published on 19 Aug 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-76227 in the wild and no public exploit code.

Affected packages and fixed versions:
- renovate (npm): affected from 42.68.1; fixed in 42.96.3
- renovate (npm): affected from 42.68.1; fixed in 42.96.3
- renovate (npm): affected from 43.0.0; fixed in 43.4.4
- renovate (npm): affected from 43.0.0; fixed in 43.4.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-76227/ (Markdown: https://insights.sbomify.com/CVE-2026-76227/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-76227
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-76227
- OSV: https://osv.dev/vulnerability/CVE-2026-76227

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-76227/
Summaries are generated and may contain mistakes; the official description above is the record.
