# CVE-2026-76228: Renovate before 42.68.5 Remote Code Execution via Gradle Wrapper

> Attackers can execute arbitrary commands in the Renovate runtime by injecting shell syntax into a Gradle wrapper URL within a scanned repository.

- **Severity:** High 8.4 (`CVSS:4.0/AV:L/AC:L/AT:N/PR:H/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 19 Aug 2026
- **Updated:** 8 Oct 2026
- **Also known as:** GHSA-mqp7-cg7m-4hhq, GHSA-pfq2-hh62-7m96

## What is CVE-2026-76228?

CVE-2026-76228 is a high-severity command injection vulnerability in mend renovate, published on 19 Aug 2026. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Renovate versions >=32.124.0 and before 42.68.5 (and Mend renovate-ce/renovate-ee before 13.3.0) contain a command injection vulnerability in Gradle Wrapper artifact handling. When Renovate processes Gradle Wrapper updates, it invokes a wrapper update command via a shell (e.g. /bin/sh -c ... ./gradlew :wrapper --gradle-distribution-url <value>). If an attacker supplies a malicious gradle-wrapper.properties whose distributionUrl contains shell command substitution syntax such as $(...), the shell evaluates it before Gradle parses the URL, resulting in arbitrary command execution in the Renovate runtime. Exploitation requires the attacker to introduce the malicious file into a repository that Renovate scans; the issue occurs even when allowScripts is disabled.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command)

## Which versions are affected by CVE-2026-76228?

2 open source packages ship an affected version, including renovate.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `renovate` | npm | From 32.124.0 | 42.68.5 |
| `renovate` | npm | From 32.124.0 | 42.68.5 |

## How do I fix CVE-2026-76228?

Upgrade renovate to 42.68.5 or later.

## Is CVE-2026-76228 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-76228 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-76228 and fix it if it is affected.

What it is: CVE-2026-76228 is a high-severity command injection vulnerability in mend renovate, published on 19 Aug 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-76228 exists.

Affected packages and fixed versions:
- renovate (npm): affected from 32.124.0; fixed in 42.68.5
- renovate (npm): affected from 32.124.0; fixed in 42.68.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-76228/ (Markdown: https://insights.sbomify.com/CVE-2026-76228/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-76228
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-76228
- OSV: https://osv.dev/vulnerability/CVE-2026-76228

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-76228/
Summaries are generated and may contain mistakes; the official description above is the record.
