# CVE-2026-76233: Renovate 39.53.0 before 40.33.0 Command Injection via gleam manager

> Attackers with repository write access can execute arbitrary commands on the Renovate host by crafting malicious gleam.toml files.

- **Severity:** High 8.4 (`CVSS:4.0/AV:L/AC:L/AT:N/PR:H/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 19 Aug 2026
- **Updated:** 19 Aug 2026
- **Also known as:** GHSA-xjr7-3c3g-m763, GHSA-xmpw-q5r4-p783

## What is CVE-2026-76233?

CVE-2026-76233 is a high-severity command injection vulnerability in renovatebot renovate, published on 19 Aug 2026. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Renovate versions from 39.53.0 before 40.33.0 contain a command injection vulnerability in the gleam manager where the depName parameter is appended to gleam deps update commands without proper sanitization. Attackers with repository write access can craft malicious gleam.toml files to execute arbitrary commands on the machine running Renovate.

Weakness: CWE-77 (Improper Neutralization of Special Elements used in a Command)

## Which versions are affected by CVE-2026-76233?

2 open source packages ship an affected version, including renovate.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `renovate` | npm | From 39.53.0 | 40.33.0 |
| `renovate` | npm | From 39.53.0 | 40.33.0 |

## How do I fix CVE-2026-76233?

Upgrade renovate to 40.33.0 or later.

## Is CVE-2026-76233 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-76233 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-76233 and fix it if it is affected.

What it is: CVE-2026-76233 is a high-severity command injection vulnerability in renovatebot renovate, published on 19 Aug 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-76233 exists.

Affected packages and fixed versions:
- renovate (npm): affected from 39.53.0; fixed in 40.33.0
- renovate (npm): affected from 39.53.0; fixed in 40.33.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-76233/ (Markdown: https://insights.sbomify.com/CVE-2026-76233/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-76233
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-76233
- OSV: https://osv.dev/vulnerability/CVE-2026-76233

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-76233/
Summaries are generated and may contain mistakes; the official description above is the record.
