{"answers":{"affected":"10 open source packages ship an affected version, including libcrux-ecdh, libcrux-ed25519 and libcrux-psq.","exploited":"There is no known exploitation of CVE-2026-76234 in the wild and no public exploit code.","fix":"Upgrade libcrux-ecdh to 0.0.6 or later.","what":"CVE-2026-76234 is a high-severity vulnerability in celabshq libcrux-ecdh, published on 19 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-76234 and fix it if it is affected.\n\nWhat it is: CVE-2026-76234 is a high-severity vulnerability in celabshq libcrux-ecdh, published on 19 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-76234 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- libcrux-ecdh (crates.io): affected all versions; fixed in 0.0.6\n- libcrux-ecdh (crates.io): affected all versions; fixed in 0.0.6\n- libcrux-ecdh (crates.io): affected from 0.0.0-0; fixed in 0.0.6\n- libcrux-ed25519 (crates.io): affected all versions; fixed in 0.0.6\n- libcrux-ed25519 (crates.io): affected all versions; fixed in 0.0.6\n- libcrux-ed25519 (crates.io): affected from 0.0.0-0; fixed in 0.0.6\n- libcrux-psq (crates.io): affected all versions; fixed in 0.0.7\n- libcrux-psq (crates.io): affected all versions; fixed in 0.0.7\n- libcrux-psq (crates.io): affected from 0.0.0-0; fixed in 0.0.7\n- libcrux-psq (crates.io): affected from 0.0.0-0; fixed in 0.0.7\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-76234/ (Markdown: https://insights.sbomify.com/CVE-2026-76234/index.md)","id":"CVE-2026-76234","markdown":"https://insights.sbomify.com/CVE-2026-76234/index.md","name":"CVE-2026-76234","record":{"aliases":["GHSA-435g-fcv3-8j26","GHSA-xp2x-phr3-m4r9","RUSTSEC-2026-0023","RUSTSEC-2026-0024","RUSTSEC-2026-0025","RUSTSEC-2026-0026"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Rust cryptographic library","requires_auth":"none","summary":"libcrux cryptographic libraries contain implementation bugs in ECDH, Ed25519, and PSQ that compromise security guarantees, requiring an upgrade to patched versions.","user_interaction":"not_required","vuln_class":"weak_cryptography"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulnCheck","cpe":[],"cvss":{"score":8.7,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-347","name":"Improper Verification of Cryptographic Signature"}],"description":"libcrux-ecdh and libcrux-ed25519 before 0.0.6, and libcrux-psq before 0.0.7, contain cryptographic implementation bugs. libcrux-ecdh did not properly check length and clamping during X25519 secret validation (and had a broken clamping check for imported X25519 secret keys); libcrux-ed25519 performed a duplicated clamping step during key generation; and libcrux-psq panicked instead of propagating an AEADError. These were fixed in the respective patched releases.","ecosystems":["crates.io"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"libcrux before 0.0.6 Cryptographic Implementation Bug Fixes","id":"CVE-2026-76234","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"crates.io","product":null,"products":[],"type":"weak_cryptography","year":"2026"},"n_packages":10,"n_references":2,"next":{"headline":"Cockpit-ws: cockpit: cockpit-ws: unauthenticated remote memory leak via cockpitlang cookie in send_login_html","id":"CVE-2026-76235"},"packages":[{"ecosystem":"crates.io","fixed":["0.0.6"],"introduced":["0"],"last_affected":[],"package":"libcrux-ecdh","purl":null,"source":"GHSA-435g-fcv3-8j26"},{"ecosystem":"crates.io","fixed":["0.0.6"],"introduced":["0"],"last_affected":[],"package":"libcrux-ecdh","purl":"pkg:cargo/libcrux-ecdh","source":"GHSA-435g-fcv3-8j26"},{"ecosystem":"crates.io","fixed":["0.0.6"],"introduced":["0.0.0-0"],"last_affected":[],"package":"libcrux-ecdh","purl":"pkg:cargo/libcrux-ecdh","source":"RUSTSEC-2026-0023"},{"ecosystem":"crates.io","fixed":["0.0.6"],"introduced":["0"],"last_affected":[],"package":"libcrux-ed25519","purl":null,"source":"GHSA-435g-fcv3-8j26"},{"ecosystem":"crates.io","fixed":["0.0.6"],"introduced":["0"],"last_affected":[],"package":"libcrux-ed25519","purl":"pkg:cargo/libcrux-ed25519","source":"GHSA-435g-fcv3-8j26"},{"ecosystem":"crates.io","fixed":["0.0.6"],"introduced":["0.0.0-0"],"last_affected":[],"package":"libcrux-ed25519","purl":"pkg:cargo/libcrux-ed25519","source":"RUSTSEC-2026-0026"},{"ecosystem":"crates.io","fixed":["0.0.7"],"introduced":["0"],"last_affected":[],"package":"libcrux-psq","purl":null,"source":"GHSA-435g-fcv3-8j26"},{"ecosystem":"crates.io","fixed":["0.0.7"],"introduced":["0"],"last_affected":[],"package":"libcrux-psq","purl":"pkg:cargo/libcrux-psq","source":"GHSA-435g-fcv3-8j26"},{"ecosystem":"crates.io","fixed":["0.0.7"],"introduced":["0.0.0-0"],"last_affected":[],"package":"libcrux-psq","purl":"pkg:cargo/libcrux-psq","source":"RUSTSEC-2026-0024"},{"ecosystem":"crates.io","fixed":["0.0.7"],"introduced":["0.0.0-0"],"last_affected":[],"package":"libcrux-psq","purl":"pkg:cargo/libcrux-psq","source":"RUSTSEC-2026-0025"}],"prev":{"headline":"Renovate 39.53.0 before 40.33.0 Command Injection via gleam manager","id":"CVE-2026-76233"},"products":["libcrux-ecdh","libcrux-ed25519","libcrux-psq"],"published":"2026-08-19","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"open","licence":"CC0 1.0","name":"RustSec","prefix":"RUSTSEC"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-08-21","vendors":["celabshq"]},"summary":"libcrux cryptographic libraries contain implementation bugs in ECDH, Ed25519, and PSQ that compromise security guarantees, requiring an upgrade to patched versions.","url":"https://insights.sbomify.com/CVE-2026-76234/"}