# CVE-2026-76237: stigmem before 0.9.0a12 Cross-Tenant BOLA via quarantine

> Cross-tenant BOLA in stigmem-node allows tenant admins to access and modify other tenants' quarantined facts in multi-tenant setups.

- **Severity:** High 8.6 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 19 Aug 2026
- **Updated:** 21 Aug 2026
- **Also known as:** GHSA-w2cf-363h-rwff, GHSA-xhv3-q4xx-349r

## What is CVE-2026-76237?

CVE-2026-76237 is a high-severity missing authorization vulnerability in eidetic-labs stigmem-node, published on 19 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

stigmem-node before 0.9.0a12 contains a broken object level authorization (cross-tenant BOLA) vulnerability in the quarantine review endpoints. On multi-tenant deployments running the opt-in stigmem-plugin-multi-tenant, the list/count queries and _get_quarantined_fact in routes/quarantine.py lacked a tenant_id predicate and the garden lookup was not tenant-scoped, allowing a tenant administrator with only a plain tenant write capability to list, read, and admit or reject quarantined facts belonging to other tenants via the /v1/quarantine endpoints. Default single-tenant deployments are not affected.

Weakness: CWE-639 (Authorization Bypass Through User-Controlled Key)

## Which versions are affected by CVE-2026-76237?

2 open source packages ship an affected version, including stigmem-node.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `stigmem-node` | PyPI | All versions | 0.9.0a12 |
| `stigmem-node` | PyPI | All versions | 0.9.0a12 |

## How do I fix CVE-2026-76237?

Upgrade stigmem-node to 0.9.0a12 or later.

## Is CVE-2026-76237 being exploited?

There is no known exploitation of CVE-2026-76237 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-76237 and fix it if it is affected.

What it is: CVE-2026-76237 is a high-severity missing authorization vulnerability in eidetic-labs stigmem-node, published on 19 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-76237 in the wild and no public exploit code.

Affected packages and fixed versions:
- stigmem-node (PyPI): affected all versions; fixed in 0.9.0a12
- stigmem-node (PyPI): affected all versions; fixed in 0.9.0a12

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-76237/ (Markdown: https://insights.sbomify.com/CVE-2026-76237/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-76237
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-76237
- OSV: https://osv.dev/vulnerability/CVE-2026-76237

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-76237/
Summaries are generated and may contain mistakes; the official description above is the record.
