# CVE-2026-76238: stigmem before 0.9.0a12 Cross-Tenant BOLA via decay sweep

> Authenticated attackers can manipulate or view data across all tenants via the decay sweep endpoint in stigmem.

- **Severity:** High 7.2 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 19 Aug 2026
- **Updated:** 25 Aug 2026
- **Also known as:** GHSA-6gqw-jqv7-v88m, GHSA-w3ff-rjv9-m452

## What is CVE-2026-76238?

CVE-2026-76238 is a high-severity missing authorization vulnerability in eidetic-labs stigmem-node, published on 19 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

stigmem versions before 0.9.0a12 contain a broken object level authorization vulnerability in the decay sweep endpoint that allows authenticated attackers with write credentials for one tenant to execute decay operations affecting all tenants. Attackers can submit POST requests to the decay sweep endpoint with ttl_seconds=0 to expire facts across all tenants, or use dry_run to obtain cross-tenant fact counts and existence information.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2026-76238?

2 open source packages ship an affected version, including stigmem-node.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `stigmem-node` | PyPI | All versions | 0.9.0a12 |
| `stigmem-node` | PyPI | All versions | 0.9.0a12 |

## How do I fix CVE-2026-76238?

Upgrade stigmem-node to 0.9.0a12 or later.

## Is CVE-2026-76238 being exploited?

There is no known exploitation of CVE-2026-76238 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-76238 and fix it if it is affected.

What it is: CVE-2026-76238 is a high-severity missing authorization vulnerability in eidetic-labs stigmem-node, published on 19 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-76238 in the wild and no public exploit code.

Affected packages and fixed versions:
- stigmem-node (PyPI): affected all versions; fixed in 0.9.0a12
- stigmem-node (PyPI): affected all versions; fixed in 0.9.0a12

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-76238/ (Markdown: https://insights.sbomify.com/CVE-2026-76238/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-76238
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-76238
- OSV: https://osv.dev/vulnerability/CVE-2026-76238

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-76238/
Summaries are generated and may contain mistakes; the official description above is the record.
