# CVE-2026-76240: stigmem Postgres SQL Injection via Schema Identifier

> Attackers can execute arbitrary SQL commands via unquoted schema identifiers in stigmem-node, potentially compromising database integrity and confidentiality.

- **Severity:** High 7.5 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:H/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 19 Aug 2026
- **Updated:** 20 Aug 2026
- **Also known as:** GHSA-9pc9-4crj-mhpj, GHSA-vgv8-r42h-hgr6

## What is CVE-2026-76240?

CVE-2026-76240 is a high-severity SQL injection vulnerability in eidetic-labs stigmem, published on 19 Aug 2026. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

stigmem-node 0.9.0a1 interpolates Postgres backend schema identifiers into SQL strings without defensive quoting. In the affected code path the schema value is operator-controlled, but the unsafe pattern could allow SQL injection if a schema name were derived from tenant, request, or user input. Fixed in 0.9.0a2, which adds identifier quoting and validation. As a workaround, only configure schema names from trusted deployment configuration.

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command)

## Which versions are affected by CVE-2026-76240?

2 open source packages ship an affected version, including stigmem-node.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `stigmem-node` | PyPI | All versions | 0.9.0a2 |
| `stigmem-node` | PyPI | All versions | 0.9.0a2 |

## How do I fix CVE-2026-76240?

Upgrade stigmem-node to 0.9.0a2 or later.

## Is CVE-2026-76240 being exploited?

There is no known exploitation of CVE-2026-76240 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-76240 and fix it if it is affected.

What it is: CVE-2026-76240 is a high-severity SQL injection vulnerability in eidetic-labs stigmem, published on 19 Aug 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-76240 in the wild and no public exploit code.

Affected packages and fixed versions:
- stigmem-node (PyPI): affected all versions; fixed in 0.9.0a2
- stigmem-node (PyPI): affected all versions; fixed in 0.9.0a2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-76240/ (Markdown: https://insights.sbomify.com/CVE-2026-76240/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-76240
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-76240
- OSV: https://osv.dev/vulnerability/CVE-2026-76240

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-76240/
Summaries are generated and may contain mistakes; the official description above is the record.
