# CVE-2026-76241: stigmem Plugin Signature Enforcement Bypass via Configuration

> Attackers can bypass plugin signature enforcement via configuration to execute arbitrary code if plugin directories are writable.

- **Severity:** High 7.3 (`CVSS:4.0/AV:L/AC:L/AT:P/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 19 Aug 2026
- **Updated:** 21 Aug 2026
- **Also known as:** GHSA-q84h-wr78-498w, GHSA-w7pm-9g55-mxfm

## What is CVE-2026-76241?

CVE-2026-76241 is a high-severity vulnerability in eidetic-labs stigmem, published on 19 Aug 2026. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

stigmem-node 0.9.0a1 allows plugin signature enforcement to be disabled via a single configuration flag without a second explicit acknowledgment. If that setting is carried into an environment where plugin directories are writable by less-trusted users, unsigned (potentially malicious) plugin code could be loaded and executed, resulting in arbitrary code execution. Fixed in 0.9.0a2, which requires a second explicit acknowledgment to disable signature enforcement.

Weakness: CWE-494 (Download of Code Without Integrity Check)

## Which versions are affected by CVE-2026-76241?

2 open source packages ship an affected version, including stigmem-node.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `stigmem-node` | PyPI | All versions | 0.9.0a2 |
| `stigmem-node` | PyPI | All versions | 0.9.0a2 |

## How do I fix CVE-2026-76241?

Upgrade stigmem-node to 0.9.0a2 or later.

## Is CVE-2026-76241 being exploited?

There is no known exploitation of CVE-2026-76241 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-76241 and fix it if it is affected.

What it is: CVE-2026-76241 is a high-severity vulnerability in eidetic-labs stigmem, published on 19 Aug 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-76241 in the wild and no public exploit code.

Affected packages and fixed versions:
- stigmem-node (PyPI): affected all versions; fixed in 0.9.0a2
- stigmem-node (PyPI): affected all versions; fixed in 0.9.0a2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-76241/ (Markdown: https://insights.sbomify.com/CVE-2026-76241/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-76241
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-76241
- OSV: https://osv.dev/vulnerability/CVE-2026-76241

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-76241/
Summaries are generated and may contain mistakes; the official description above is the record.
