# CVE-2026-76243: stigmem before 0.9.0a2 Authentication Bypass via Disabled Auth

> Attackers can perform read, write, and federation operations with anonymous identity when authentication is disabled on non-loopback deployments.

- **Severity:** Critical 9.2 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 19 Aug 2026
- **Updated:** 25 Aug 2026
- **Also known as:** GHSA-fp6w-8wpg-74g5, GHSA-rqm4-4g3h-95wm

## What is CVE-2026-76243?

CVE-2026-76243 is a critical authentication bypass vulnerability in eidetic-labs stigmem, published on 19 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

stigmem versions before 0.9.0a2 allow unauthenticated access when authentication is disabled on non-loopback deployments. Attackers can perform read, write, and federation operations with anonymous identity when nodes are exposed outside local development environments.

Weakness: CWE-285 (Improper Authorization)

## Which versions are affected by CVE-2026-76243?

2 open source packages ship an affected version, including stigmem-node.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `stigmem-node` | PyPI | All versions | 0.9.0a2 |
| `stigmem-node` | PyPI | All versions | 0.9.0a2 |

## How do I fix CVE-2026-76243?

Upgrade stigmem-node to 0.9.0a2 or later.

## Is CVE-2026-76243 being exploited?

There is no known exploitation of CVE-2026-76243 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-76243 and fix it if it is affected.

What it is: CVE-2026-76243 is a critical authentication bypass vulnerability in eidetic-labs stigmem, published on 19 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-76243 in the wild and no public exploit code.

Affected packages and fixed versions:
- stigmem-node (PyPI): affected all versions; fixed in 0.9.0a2
- stigmem-node (PyPI): affected all versions; fixed in 0.9.0a2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-76243/ (Markdown: https://insights.sbomify.com/CVE-2026-76243/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-76243
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-76243
- OSV: https://osv.dev/vulnerability/CVE-2026-76243

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-76243/
Summaries are generated and may contain mistakes; the official description above is the record.
