# CVE-2026-76244: stigmem-node Insecure Federation Transport Configuration

> Operators disabling mTLS on non-loopback federation endpoints expose traffic to interception and man-in-the-middle attacks.

- **Severity:** Critical 9.1 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 19 Aug 2026
- **Updated:** 19 Aug 2026
- **Also known as:** GHSA-jmfc-hfjq-pxcp, GHSA-pxm8-2h3h-jwmv

## What is CVE-2026-76244?

CVE-2026-76244 is a critical vulnerability in eidetic-labs stigmem, published on 19 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

stigmem-node contains an insecure default configuration vulnerability that allows federation traffic to traverse networks without mTLS protection when non-loopback endpoints are enabled. Operators who explicitly disabled mTLS while binding federation to non-loopback addresses expose federation traffic to cleartext interception and man-in-the-middle attacks.

Weakness: CWE-319 (Cleartext Transmission of Sensitive Information)

## Which versions are affected by CVE-2026-76244?

2 open source packages ship an affected version, including stigmem-node.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `stigmem-node` | PyPI | All versions | 0.9.0a2 |
| `stigmem-node` | PyPI | All versions | 0.9.0a2 |

## How do I fix CVE-2026-76244?

Upgrade stigmem-node to 0.9.0a2 or later.

## Is CVE-2026-76244 being exploited?

There is no known exploitation of CVE-2026-76244 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-76244 and fix it if it is affected.

What it is: CVE-2026-76244 is a critical vulnerability in eidetic-labs stigmem, published on 19 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-76244 in the wild and no public exploit code.

Affected packages and fixed versions:
- stigmem-node (PyPI): affected all versions; fixed in 0.9.0a2
- stigmem-node (PyPI): affected all versions; fixed in 0.9.0a2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-76244/ (Markdown: https://insights.sbomify.com/CVE-2026-76244/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-76244
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-76244
- OSV: https://osv.dev/vulnerability/CVE-2026-76244

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-76244/
Summaries are generated and may contain mistakes; the official description above is the record.
