# CVE-2026-76245: stigmem Federation Peer Token Timestamp Validation Bypass

> Attackers can cause denial of service in authenticated federation flows by exploiting timestamp validation flaws in the stigmem library.

- **Severity:** High 7.1 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 19 Aug 2026
- **Updated:** 20 Aug 2026
- **Also known as:** GHSA-rh24-296r-8rj6, GHSA-xh5j-xjfq-qvvx

## What is CVE-2026-76245?

CVE-2026-76245 is a high-severity authentication bypass vulnerability in eidetic-labs stigmem, published on 19 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

stigmem (pip package stigmem-node) version 0.9.0a1 contains a timestamp-handling mismatch in federation peer-token validation that can cause valid peer tokens to be incorrectly treated as expired. This affects the availability and reliability of authenticated federation flows on nodes using federation peer authentication paths. The issue is fixed in 0.9.0a2, which uses the canonical millisecond-based validation path.

Weakness: CWE-345 (Insufficient Verification of Data Authenticity)

## Which versions are affected by CVE-2026-76245?

2 open source packages ship an affected version, including stigmem-node.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `stigmem-node` | PyPI | All versions | 0.9.0a2 |
| `stigmem-node` | PyPI | All versions | 0.9.0a2 |

## How do I fix CVE-2026-76245?

Upgrade stigmem-node to 0.9.0a2 or later.

## Is CVE-2026-76245 being exploited?

There is no known exploitation of CVE-2026-76245 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-76245 and fix it if it is affected.

What it is: CVE-2026-76245 is a high-severity authentication bypass vulnerability in eidetic-labs stigmem, published on 19 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-76245 in the wild and no public exploit code.

Affected packages and fixed versions:
- stigmem-node (PyPI): affected all versions; fixed in 0.9.0a2
- stigmem-node (PyPI): affected all versions; fixed in 0.9.0a2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-76245/ (Markdown: https://insights.sbomify.com/CVE-2026-76245/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-76245
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-76245
- OSV: https://osv.dev/vulnerability/CVE-2026-76245

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-76245/
Summaries are generated and may contain mistakes; the official description above is the record.
