CVE-2026-76572 pkp pkp-lib XSLTransformer.php _transformPHP xml external entity reference
Remote attackers can exploit an XML External Entity vulnerability in the XSLTransformer to read sensitive data or cause denial of service.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- None listed
What is CVE-2026-76572?
CVE-2026-76572 is a medium-severity vulnerability in pkp-lib, published on 19 Aug 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Official description
A vulnerability was detected in pkp pkp-lib up to 3.3.0-22/3.4.0-10/3.5.0-4. The affected element is the function _transformPHP of the file classes/xslt/XSLTransformer.php. The manipulation results in xml external entity reference. The attack can be executed remotely. Upgrading to version 3.3.0-23, 3.4.0-11 and 3.5.0-5 is sufficient to fix this issue. The patch is identified as 78c699370ea43ae2784e1c4ace7c947d207f2b47. Upgrading the affected component is advised.
Which versions are affected by CVE-2026-76572?
How do I fix CVE-2026-76572?
No fix has been published for CVE-2026-76572 yet. Limit exposure of the affected software until one is available.
Is CVE-2026-76572 being exploited?
There is no known exploitation of CVE-2026-76572 in the wild and no public exploit code.
Sources
Also known as GHSA-8j8f-r97j-fp5x.