{"answers":{"affected":"","exploited":"There is no known exploitation of CVE-2026-76572 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2026-76572 yet. Limit exposure of the affected software until one is available.","what":"CVE-2026-76572 is a medium-severity vulnerability in pkp-lib, published on 19 Aug 2026. An attacker needs administrator access to exploit it, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-76572 and fix it if it is affected.\n\nWhat it is: CVE-2026-76572 is a medium-severity vulnerability in pkp-lib, published on 19 Aug 2026. An attacker needs administrator access to exploit it, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-76572 in the wild and no public exploit code.\n\nAffected product: pkp-lib. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-76572/ (Markdown: https://insights.sbomify.com/CVE-2026-76572/index.md)","id":"CVE-2026-76572","markdown":"https://insights.sbomify.com/CVE-2026-76572/index.md","name":"CVE-2026-76572","record":{"aliases":["GHSA-8j8f-r97j-fp5x"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read","denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"PKP pkp-lib library","requires_auth":"high_privilege","summary":"Remote attackers can exploit an XML External Entity vulnerability in the XSLTransformer to read sensitive data or cause denial of service.","user_interaction":"not_required","vuln_class":"xxe"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulDB","cpe":[],"cvss":{"score":5.1,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:X","version":"4.0"},"cwes":[{"id":"CWE-611","name":"Improper Restriction of XML External Entity Reference"},{"id":"CWE-610","name":"Externally Controlled Reference to a Resource in Another Sphere"}],"description":"A vulnerability was detected in pkp pkp-lib up to 3.3.0-22/3.4.0-10/3.5.0-4. The affected element is the function _transformPHP of the file classes/xslt/XSLTransformer.php. The manipulation results in xml external entity reference. The attack can be executed remotely. Upgrading to version 3.3.0-23, 3.4.0-11 and 3.5.0-5 is sufficient to fix this issue. The patch is identified as 78c699370ea43ae2784e1c4ace7c947d207f2b47. Upgrading the affected component is advised.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":false,"headline":"pkp pkp-lib XSLTransformer.php _transformPHP xml external entity reference","id":"CVE-2026-76572","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"xxe","year":"2026"},"n_packages":0,"n_references":8,"next":{"headline":"Pods \u003c= 3.3.9.1 - Authenticated (Contributor+) Stored Cross-Site Scripting via 'not_found' Shortcode Attribute","id":"CVE-2026-76573"},"packages":[],"prev":{"headline":"Joomla Extension - fabrikar.com - Unauthenticated SQL injection in list filter condition parameter in Fabrik \u003c 4.7.2","id":"CVE-2026-76571"},"products":["pkp-lib"],"published":"2026-08-19","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-08-20","vendors":["pkp"]},"summary":"Remote attackers can exploit an XML External Entity vulnerability in the XSLTransformer to read sensitive data or cause denial of service.","url":"https://insights.sbomify.com/CVE-2026-76572/"}