# CVE-2026-76572: pkp pkp-lib XSLTransformer.php _transformPHP xml external entity reference

> Remote attackers can exploit an XML External Entity vulnerability in the XSLTransformer to read sensitive data or cause denial of service.

- **Severity:** Medium 5.1 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:X`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 19 Aug 2026
- **Updated:** 20 Aug 2026
- **Also known as:** GHSA-8j8f-r97j-fp5x

## What is CVE-2026-76572?

CVE-2026-76572 is a medium-severity vulnerability in pkp-lib, published on 19 Aug 2026. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

A vulnerability was detected in pkp pkp-lib up to 3.3.0-22/3.4.0-10/3.5.0-4. The affected element is the function _transformPHP of the file classes/xslt/XSLTransformer.php. The manipulation results in xml external entity reference. The attack can be executed remotely. Upgrading to version 3.3.0-23, 3.4.0-11 and 3.5.0-5 is sufficient to fix this issue. The patch is identified as 78c699370ea43ae2784e1c4ace7c947d207f2b47. Upgrading the affected component is advised.

Weakness: CWE-611 (Improper Restriction of XML External Entity Reference), CWE-610 (Externally Controlled Reference to a Resource in Another Sphere)

## Which versions are affected by CVE-2026-76572?


## How do I fix CVE-2026-76572?

No fix has been published for CVE-2026-76572 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-76572 being exploited?

There is no known exploitation of CVE-2026-76572 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-76572 and fix it if it is affected.

What it is: CVE-2026-76572 is a medium-severity vulnerability in pkp-lib, published on 19 Aug 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-76572 in the wild and no public exploit code.

Affected product: pkp-lib. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-76572/ (Markdown: https://insights.sbomify.com/CVE-2026-76572/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-76572
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-76572
- OSV: https://osv.dev/vulnerability/CVE-2026-76572

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-76572/
Summaries are generated and may contain mistakes; the official description above is the record.
