# CVE-2026-76801: FireBox <= 3.1.10 - Authenticated (Author+) Remote Code Execution to Privilege Escalation

> Authenticated attackers with author-level access can execute arbitrary code and escalate privileges due to insufficient input sanitization in the FireBox WordPress plugin.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 9 Sep 2026
- **Updated:** 9 Sep 2026
- **Also known as:** GHSA-48j6-7xh6-vcfv

## What is CVE-2026-76801?

CVE-2026-76801 is a high-severity code injection vulnerability in fireplugins FireBox – WooCommerce Popup Builder, Exit Intent Popup, Email Optin & Cart Abandonment, published on 9 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

The FireBox – WooCommerce Popup Builder, Exit Intent Popup, Email Optin & Cart Abandonment plugin for WordPress is vulnerable to Remote Code Execution in all versions up to, and including, 3.1.10 via the value function. This is due to a trivially bypassable regex blacklist in Executer::allowedToRun() that fails to block WordPress core functions such as wp_insert_user, update_option, and file_put_contents, combined with no sanitization of PHP condition rule values stored via the firebox_meta REST endpoint. This makes it possible for authenticated attackers, with author-level access and above, to execute code on the server. On sites upgraded from a version prior to 3.1.10, the Migrator::preserveCampaignRoleAccess() function automatically grants the edit_fireboxes and publish_fireboxes capabilities to the Author role, lowering the effective entry point to Author-level access.

Weakness: CWE-269 (Improper Privilege Management)

## Which versions are affected by CVE-2026-76801?


## How do I fix CVE-2026-76801?

No fix has been published for CVE-2026-76801 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-76801 being exploited?

There is no known exploitation of CVE-2026-76801 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-76801 and fix it if it is affected.

What it is: CVE-2026-76801 is a high-severity code injection vulnerability in fireplugins FireBox – WooCommerce Popup Builder, Exit Intent Popup, Email Optin & Cart Abandonment, published on 9 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-76801 in the wild and no public exploit code.

Affected product: fireplugins FireBox – WooCommerce Popup Builder, Exit Intent Popup, Email Optin & Cart Abandonment. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-76801/ (Markdown: https://insights.sbomify.com/CVE-2026-76801/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-76801
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-76801
- OSV: https://osv.dev/vulnerability/CVE-2026-76801

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-76801/
Summaries are generated and may contain mistakes; the official description above is the record.
