# CVE-2026-76805: Nuclei: Environment Variable Disclosure via Response-Derived Data in DAST/Fuzz Mode

> A malicious scan target can disclose scanner-host environment variables if the -env-vars flag is enabled during DAST or fuzz operations.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 22 Sep 2026
- **Updated:** 22 Sep 2026
- **Also known as:** GHSA-jpvm-9frm-hjcq, GO-2026-6571

## What is CVE-2026-76805?

CVE-2026-76805 is a medium-severity vulnerability in projectdiscovery nuclei, published on 22 Sep 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Nuclei is a vulnerability scanner built on a simple YAML-based DSL. From 3.0.0 until 3.10.0, the DAST/fuzz payload path in pkg/fuzz/parts.go can evaluate substituted runtime data more than once, creating a second evaluation pass that allows response content captured by an internal: true extractor in one protocol step to be reinterpreted as template syntax in a later fuzz step. This vulnerability is an incomplete fix for CVE-2026-41645: the prior remediation made expressions.Evaluate() single-pass within one call but did not prevent DAST/fuzz callers from evaluating substituted output again. When -env-vars is enabled, a malicious scan target can return marker-shaped content that resolves against the template variable map and discloses scanner-host environment variables such as credentials, API keys, or tokens. The vulnerability requires a multi-step DAST or fuzz template, response data reused through an internal extractor, and explicit environment-variable expansion; users who do not enable -env-vars are not affected by the sensitive-information disclosure. This issue is fixed in version 3.10.0.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2026-76805?

5 open source packages ship an affected version, including github.com/projectdiscovery/nuclei/v3, github.com/projectdiscovery/nuclei and github.com/projectdiscovery/nuclei/v2.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/projectdiscovery/nuclei/v3` | Go | From 3.0.0 | 3.10.0 |
| `github.com/projectdiscovery/nuclei/v3` | Go | From 3.0.0 | 3.10.0 |
| `github.com/projectdiscovery/nuclei/v3` | Go | From 3.0.0 | 3.10.0 |
| `github.com/projectdiscovery/nuclei` | Go | All versions | None |
| `github.com/projectdiscovery/nuclei/v2` | Go | All versions | None |

## How do I fix CVE-2026-76805?

Upgrade github.com/projectdiscovery/nuclei/v3 to 3.10.0 or later.

## Is CVE-2026-76805 being exploited?

There is no known exploitation of CVE-2026-76805 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-76805 and fix it if it is affected.

What it is: CVE-2026-76805 is a medium-severity vulnerability in projectdiscovery nuclei, published on 22 Sep 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-76805 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/projectdiscovery/nuclei/v3 (Go): affected from 3.0.0; fixed in 3.10.0
- github.com/projectdiscovery/nuclei/v3 (Go): affected from 3.0.0; fixed in 3.10.0
- github.com/projectdiscovery/nuclei/v3 (Go): affected from 3.0.0; fixed in 3.10.0
- github.com/projectdiscovery/nuclei (Go): affected all versions; no fix listed
- github.com/projectdiscovery/nuclei/v2 (Go): affected all versions; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-76805/ (Markdown: https://insights.sbomify.com/CVE-2026-76805/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-76805
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-76805
- OSV: https://osv.dev/vulnerability/CVE-2026-76805

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-76805/
Summaries are generated and may contain mistakes; the official description above is the record.
